One Arduino Working, Another Not

I have an Arduino Uno (Uno R3 clone from Elegoo) that I can't connect to the Arduino IDE anymore (it used to connect fine and the program on it still runs) on two separate computers (both Windows 10). What's odd is I have another Uno clone that connects fine. I tried the loopback test but I don't get a device-insertion tone and the serial monitor gives me an error that it can't start monitoring. I check the Windows Device Manager and it didn't show anything under "Ports (COM & LPT)" so I tried installing it by "Add Legacy Hardware" but I get the error "This device cannot start. (Code 10)
The specified request is not a valid operation for the target device."

Any ideas?

Thank you

Start with the two links below.

Could you take a few moments to Learn How To Use The Forum.
It will help you get the best out of the forum in the future.
Other general help and troubleshooting advice can be found here.

Code 10 IS a driver issue for Windows and there are multiple probable causes and just as many fixes.

Most clones is a CH340/341 driver as mentioned in the link above.

I tried installing the CH340/341 driver but the issue persists.

I'm using version 1.8.12 of the Arduino IDE.

I'm using version 1.8.3 of the "Arduino AVR Boards".

I tried running the IDE as an administrator but it didn't help.

IDE selection is ond efault "AVRISP mkII".

Nothing is connected to the Arduino Uno except the USB cable. I've tried 3 different cables on 2 different PCs. I've also tried multiple USB 2 ports.

The "Ports" menu is greyed out on in the IDE (see attached screenshot).

There are no other serial programs running.

The green LED is on
.
The board isn't touching anything metallic or conductive.

I'm in the United States.

I'm also attaching three photos of the board.

Note that this did used to work (e.g. upload code to the board) without any additional drivers or settings changes.

Thanks

It certainly looks like one of the better clones with a real Atmel chip for the USB.

Only problem is those chips are prone to breakage or bootloader failure on occasion.
Quite often if that is the only issue they can still be either risen from the dead by using another working board to replace the bootloader or still programmed via the ICSP if the smaller atmel is dead.

Looks like a very dusty board too :fearful:

Thanks, I'll try programming via the ICSP.

попробуйте переустановить драйвера для юсб портов на компьютере. Возможно драйвер юсб глючит..