Please upgrade your Yún - latest is 1.4.2

Hi everyone

another release of OpenWrt-Yun is available. You can download it from

1.4.2 includes both bug fixes and new stuff. We fixed some glitches in the webpanel (a bug was found by wildpalms: thank you!) The OpenWRT Image Builder and the software produced by the is now available for download

Compared to 1.4.1 this release contains:

The complete list of changes is available at

Were there any bugs pertaining to the serial port?

I compiled my own YUN openwrt from the source and added my own C program that communicates over the serial port to the YUN arduino, however the communication has many problems, missing bytes, wrong byte received etc,even when I dialed down the baud rate to only 300, still errors.

I'm opening /dev/ttyATH0 from linux code on YUN, and used serial1 channel on arduino,simple serial communications dont work even when I removed this line from inittab still get lots of errors.

ttyATH0::askfirst:/bin/ash --login

will the new YUN update fix this serial problems? Is another process opening port too while I'm using it on linux?

Please help!!

rouch_neck: Were there any bugs pertaining to the serial port?

Nope sorry. Perhaps you want to post your issues on (where you've already commented) double checking if any available updates, on both openwrt yun and java ide, fix the problem.

Also, you may want to test the quality of ttyATH0 using some already available software, like python's pyserial, just to be sure the bug is not in your code.

I haven't done anything with the Yun for a while and came back tonight read this and was interested in upgrading my Yun. Downloaded the image then read the big red alert informing me that going ahead will Void the warranty on the Yun. (


For now I have chosen not to reflash.

That's the advanced, low level and dangerous way. There is a safer and easier one:

Thank you will investigate.

Just as a helpful hint to the new folk...can you add the "please upgrade" to the "Getting Started" guide?

Good point! I'll have the docs updated asap


I did the upgrade and it worked fined.
But, I noticed that the linux kernel version is an old one.
In the old version the kernel was 3.8.3, and after the update, it was downgraded to 3.3.8.
See pictures 4 and 7 from our blog

Is it on purpose?

Thanx for the great job,

eddybower: Is it on purpose?