Problem with RA6963 LCD

hello
I bought 160x128 LCD

(this is the seller's page of the lcd)

So I wire lcd to my arduino mega, but it doesn't work, only back light is working!

can you tell me what is the problem?
wiring


FG- GND
VSS - GND
VDD -5V(I also use addtional power)
V0 - 20K pot 2pin
V out - 20K pot 1 pin // 20K pot 3 pin - GND
WR - 17
Rd - 18
CS - 14
CD - 15
HALT - GND
RST - 16
DB0~DB7 - [8,9,10,11,4,5,6,7]
NC - NC
BLA - 5V
BLK - GND

And this is the code that I found in instructables

#include "U8glib.h"

U8GLIB_T6963_240X128 u8g(8, 9, 10, 11, 4, 5, 6, 7, 14, 15, 17, 18, 16);
// 8Bit Com: D0..D7: D0, D1, D2, D3, D4, D5, D6, D7, cs=14, c/d(a0)=15, wr=17, rd=18, reset=16

void draw(void) {
// graphic commands to redraw the complete screen should be placed here
//Selecting Font
u8g.setFont(u8g_font_6x10);
//Draw String on the screen
u8g.drawStr( 0, 22, "I am Pranav Sharma");
}

void setup(void) {

}

void loop(void) {
// picture loop
u8g.firstPage();
do {
draw();
} while( u8g.nextPage() );

// rebuild the picture after some delay
delay(50);
}

please help me.......

I strongly advise using u8g2lib since u8glib is no longer supported. e.g.

U8G2_T6963_240X128_1_8080(rotation, d0, d1, d2, d3, d4, d5, d6, d7, enable, cs, dc [, reset]) [page buffer, size = 240 bytes]

For your wiring scheme use this constructor with any of the "paged" examples from U8g2 library.

U8G2_T6963_240X128_1_8080 u8g2(U8G2_R0, 8, 9, 10, 11, 4, 5, 6, 7, 17, 14, 15, 16); // Connect RD, HALT with +5V

Note that there are an awful lot of wires to connect. I suggest that you post a photo that clearly shows the wires.

David.