Problema Arduino

Ciao a tutti, premetto che ho un'arduino mega 2560 cinese, ho caricato lo sketch blink con il pin13 ed è andato, dopo ho caricato il 12 e non è andato, da cosa dipende ?

Buonasera, essendo il tuo primo post, nel rispetto del regolamento, ti chiedo cortesemente di presentarti QUI ([u]spiegando bene quali conoscenze hai di elettronica e di programmazione[/u] ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con attenzione il su citato REGOLAMENTO ... Grazie.

Guglielmo

Oscaretto: ... ho caricato lo sketch blink con il pin13 ed è andato, dopo ho caricato il 12 e non è andato, da cosa dipende ?

Dopo aver fatto quanto qui sopra richiesto ... se spieghi meglio .. perché così non ho capito cosa vuoi sapere ... ::)

Guglielmo

ho questo codice che ho caricato e ha funzionato:

// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin LED_BUILTIN as an output.
  pinMode(13, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(13, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);                       // wait for a second
  digitalWrite(13, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);                       // wait for a second
}

ora metto questo codice e dopo averlo ricaricato rimane ancora il pin 13 che il 12

// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin LED_BUILTIN as an output.
  pinMode(12, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(12, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);                       // wait for a second
  digitalWrite(12, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);                       // wait for a second
}

Oscaretto: ora metto questo codice e dopo averlo ricaricato rimane ancora il pin 13 che il 12

Cioè ? Blinka sia il 12 che il 13 oppure blinka ancora solo il 13 ? Se blinka solo il 13, hai compilato ma fatto anche l'upload sulla mega ?

ho uploadato quello con il 13 ed è partito, poi voglio caricare un'altro sketch e rimane al precendente

ciao ma per controllare il led 12 stai usando un led esterno??? prova a invertire la polarità magari è sbagliata… ma se non funziona prova a fare un programma che ti permetta di attivare contemporaneamente sia il led 13 e 12 fai questo con 2 led esterni. Ancora non va il dodici?? Prova gli altri e vedi cosa combinano ma senza il 13 fai questo controllo molto scrupolosamente!!

Oscaretto: ho uploadato quello con il 13 ed è partito, poi voglio caricare un'altro sketch e rimane al precendente

L'upload da msg di okay ?