Problemas con mi arduino Uno ( no cargan los programas) [SOLUCIONADO]

Hace unos meses compre un arduino Uno el cual hasta ahora e comenzado a usar por que antes no era necesario, bueno, el problema con este arduino es que cada ves que intento cargar un programa en el me aparece el siguiente error

Binary sketch size: 960 bytes (of a 30720 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

No se que quiera decir pero no me deja cargar ni 1 solo programa en la placa arduino... ya intente y verifique todo lo que creía posible, el led que esta sobre el pin 13 anaranjado parpadea perfectamente y el led verde estático también permanece encendido.

Por favor me podrían ayudar diciéndome que es lo que pasa y cual es la solución a este problema en verdad que me urge comenzar a utilizarlo...

MUCHISIMAS GRACIAS

98% de probabilidad de que hayas seleccionado mal la placa en el IDE

Si puedes responder por el foro mejor

Aquí tienes lo que necesitas: http://arduino.cc/es/Guide/HomePage

tengo la versión 0023 tenia entendido que esa es la mas reciente estoy en lo correcto?

la versión más reciente es la 1.0

e instalado la nueva version y tengo un nuevo error es el siguiente:

avrdude stk500_getsync not in sync resp 0x30

no tengo ni idea de que pueda ser : :~

Has mirado el enlace que te he puesto antes?

Si lo e visto y leido completamente aparte de haber realizado cada paso al pie de la letra solo que Al momento de que conecte el arduino a la computadora no me aparecio nada sobre instalacion de drivers podria ser esto? Utilizo windows 7 y dice que se instalan automaticamente

El problema fue que uno de los controladores no se instalaba en mi computadora pero a quedado solucionado ;)

disculpa como hiciste para que el driver funcionara??? tengo el mismo problema