Problème avec la tension de sortie capteur inductif

Bonjour !

J'essaie d'utiliser actuellement un capteur inductif afin de pouvoir détecter de l'acier, il est de type NPN.

Capteur: https://www.amazon.fr/gp/aw/d/B07912K2NB/ref=ox_sc_saved_image_6?smid=A80IWAZC4BCUO&psc=1

Je l'alimente en 12v en utilisant un régulateur de tension step up, pour passer de 5v à 12v.

Le capteur envoie 12v lorsqu'il ne détecte rien et 0v lors d'une détection. Du coup, il faut que je diminue cette tension afin de pouvoir l'utiliser sur mon arduino.

Alors j'ai le choix, soit j'utilise un pont diviseur de tension ou un régulateur de tension step down.

Seulement voilà: je mesure la tension du file de sortie du capteur qui est bien de 12v mais quand je mesure au borne de la résistance ou du régulateur c'est de 3,75v... Alors que j'ai juste branché le fil, la tension change, je ne comprends pas.

Merci d'avance!

Bonsoir

Un petit schéma, même à main levée avec les valeurs des résistances du pont diviseur permettrait d’y voir plus clair.

Est-ce que le 12V en sortie du capteur, à vide, à été réellement constatée en cas de détection ?
Si oui ça correspondrait à une sortie dite ‘PNP’, pas 'NPN

La sortie du capteur est annoncée comme “NPN/NO” donc contact à la masse ouvert au repos
NPN.jpg
En principe un capteur à sortie ‘NPN’ (si la description du site correspond à la réalité) ne fournit pas de tension sur sa sortie, il y a juste un contact entre sortie et masse , ‘normalement ouvert’ en absence de détection.

Dans ce cas on met une résistance de tirage ''pull up" vers la tension qui nous arrange …5V içi
pas besoin de pont diviseur ou autre…
capteur sortie npn.jpg