Problème avec un exo pour débutant

Bonjour à tous, désolé de déranger cette belle comunauté mais jai un problème avec cet exercice qui parle de “faire tourner son moteur dans 1 sens gâce à un interrupteur”
Me voilà bien embeté car mon prof d’sti2d ne nous a pas montré comment coder tout ça
Je fais appel à tous vos conseil et sur ce merci d’avance pour les plus intéressé par ce problème

Ca peut même fonctionner sans la carte Arduino :wink:

bonjour,
dans les exemples de l'ide, il n'y aurait pas quelque chose qui y ressemble?
style allumer une led

Merci à vous mais le ic c'est qu'il n'y a pas d'aide ni doc pour comprendre la situation c'est pour ça que c'est la galère

Zotec:
Merci à vous mais le ic c'est qu'il n'y a pas d'aide ni doc pour comprendre la situation c'est pour ça que c'est la galère

et si tu cherchais un peu avec les indications données?
allumer eteindre led arduino
environ 10000 liens sur gogole

je plussoit et pour aller encore plus loin dans l'assistanat je dirai ceci:

-fichier
-exemples
-digital
-b....

ce qui correspond presque a 100% a la demande (si je ne m'abuse il n'y a que deux chiffres a modifier)

ça ira !??

yep finalement je l'ai fait tourner sous proteus avec le code suivant :

const int MO = 12;
const int BP = 13;
int test = 0;

void setup()
{
pinMode(MO, OUTPUT);
pinMode(BP, INPUT);
}

void loop()
{
test = digitalRead(BP);

if(test==HIGH)
{
digitalWrite(MO, HIGH);
}

else
{
digitalWrite(MO, LOW);
}
}

Bonjour,
c’est immédiatement compréhensible pour un habitué, mais pour un débutant il serait bien de rajouter quelques commentaires : ton topic sera vu des dizaines de fois et certains lecteurs se demanderont dans le détail du code ce que tu as voulu faire

code entre balise code </>

et un merci, ca ne fait pas de mal