Problème compilation

Bonjour a tous, je viens vers vous car depuis un jour je n'arrive plus a compiler quoi que ce soit dans l’environnement arduino: la barre de progression reste figée a environ un tier .Parfois une erreur apparaît : "No such file or directory" .J'ai essayer plusieurs versions d’environnement arduino sans succès . Quelqu'un aurait la solution ?

Bonjour,

Code ? Message d'erreur complet ? Version de l'ide ? Carte utilisé ?

Code: n’importe lequel, meme sans insctructions !! Message d'erreur complet: soir rien et arrret de la barre de progresssion, soit "cc1plus.exe: error: AnalogReadSerial.cpp: No such file or directory" (diffère selon le code) Version de l'Ide : plusieurs (1.0.1, 1.0.0, 0023,...) Carte utilisé: aucune car pas de compilation (mais sinon c'est une mega 2560/ADK)

wwAGHww: Code: n’importe lequel, meme sans insctructions !! Message d'erreur complet: soir rien et arret de la barre de progresssion, soit "cc1plus.exe: error: AnalogReadSerial.cpp: No such file or directory" (diffère selon le code)

Oula ça sent l'installation foireuse ;)

Tu utilise le zip téléchargé depuis le site officiel arduino.cc ou une version modifié ? Que l'ide aille chercher cc1plus.exe me semble un peu louche ...

Je suppose que tu est sous windows ? Quelle version (XP, vista, seven, 8, ...) ?

"Installation foireuse" je ne me rappelle pas avoir fait d’installation pour l'ide arduino ! Télécharger en officiel sans aucune modification Et je suis suis sous Windows 7 édition familial premium.

wwAGHww: "Installation foireuse" je ne me rappelle pas avoir fait d’installation pour l'ide arduino !

Par "installation foireuse" je sous entend le "package arduino" dans son intégralité (runtime java + ide + core arduino + compilateur). Normalement tu télécharge le zip, tu le dézippe quelque pars et tu lance arduino.exe (et tout marche ... normalement).

wwAGHww: Télécharger en officiel sans aucune modification Et je suis suis sous Windows 7 édition familial premium.

C'est vraiment bizarre, le chemin jusqu'au dossier arduino contient-il des espaces ? Est-ce que le dossier qui contient l'installation arduino à bien les droits pour l'utilisateur ? Quel est le chemin vers ton dossier arduino ?

Comment vérifier l’intégrité du "pakage" ? Et le chemin n'a pas d'espace, meme en le plaçant a la racine j'ai toujours le meme probleme.

Il est plus rapide de réinstaller le package complet que de chercher le fichier qui manque.

Christian_R: Il est plus rapide de réinstaller le package complet que de chercher le fichier qui manque.

Je plussoie.

Du reste il n'existe aucun fichier de checksum pour vérifier l'intégrité du package téléchargé (ce qui est une erreur de la pars de la team arduino ...).

J'ai trouver la "solution" du moins j'ai régler le problème: j'ai mis a jours java, j'ai tout télécharger et maintenant tout marche ! Merci comme de m'avoir aidé.