Problems with JSN-SR04T

Hey guys, this is my first post here so please let me know if i've done anything out of pattern or recommendations.

I've been trying to build a water level monitoring using this waterproof ultrasonic sensor (the JSN-SR04T) and an ESP8266 WiFi module, so I can have the measurement through a simple login into the adafruit platform. So let's get to the problem, i don't know why but when I try reading the distance using the ESP8266, the JSN-SR04T and a Bi-directional logic converter, every read I get is 0, I've also tried starting the variables I'm using as different than 0 to confirm that it is reading something and I still get 0 in the end. When I use an Arduino UNO spare board that I have, there's no problem at all in reading the distance.

I would appreciate a lot if you guys could help me out with this one.

Thanks in advance

I believe you are operating everything on 3.5 volts. The Google says: Electrical properties: Electrical parameters:JSN-SR04T Operating voltage: DC 5V Quiescent current: 5mA Total current work: 30mA Acoustic emission frequency: 40khz Farthest distance: 4.5m Blind: 25cm Wiring: + 5V (positive power supply) Trig (control side) RX Echo (the receiver) TX GND (negative) Module size: 41mm * ... Arduino Waterproof JSN-SR04T Ultrasonic Sensor (2 Examples)
Let us know how it works out.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.