Problems with using the ArduinoUno with the Rainbowduino

hey guys, i´m a beginner searching for some answers to my stupid questions XD Please be appreciative, as i sad i´m new at all this, but I need to do this for school...and sorry for my bad englisch^^

I´d like to use my rainbowduino with my ArduinoUno...and maybe with the mtXcontrol... I tried to follow the instructions on this page: So I -installed arduino -Choosed the right Board (Arduino UNo) and the right SerialPort (COM5) -Uploaded blank sketch

-connected the 5Wires as shown on the picture

But than: I loaded the firmware.pde sketch on the Arduino IDE and tried to upload it, but than he shows me the massage: Rainbowduinodoes not name a type while marking the line: Rainbowduino rainbow = Rainbowduino(); //max 10 Frames

I guess it´s because I didn´t chenged the processor type to 168, because my ArduinoUno has an 328... Or did i do smt. diffrent totally wrong? :P -If it´s the processor type do I change the processor type?

I've had numerous disappointments before trying to make mtXcontrol work and i found this posted someplace else and I used it successfully for the mtXcontrol sketch:

The new version of mtXcontrol and corresponding firmware run on rainbowduino may not work, so you may try this (I've tested ok):

  1. Download the and here:

  2. Connect your rainbowduino in proper way to your computer that you can program it through COM.(Remember to change the port to use COM1)...this is very important!!! this version of mtXcontrol was hardcoded for COM1

  3. Unzip to your arduino code directory (no need in the arduino library), open Rainbow_mtX.pde by arduino and program it to your rainbowduino.(If it compiles failed, there may be another rainbowduino class in your arduino library, so back up and remove it). After programmed, the rainbow Matrix will be all in white.

  4. Unzip and run mtXcontrol.exe. If there's error reported, like "not found javaw.exe", then you need to add the java path to your environment variable (On my computer is: D:\Program Files\arduino-0018\java\bin ). Am I understood? If there's no error reported, just enjoy controlling your rainbow!

hi ortsac,

it does not work at my ArduinoUno with the Rainbowduino. my steps:

  1. Download the and
  2. I connect my Rainbowduino with my ArduinoUno to my computer, like this
    the Rainbowduino the lights as the image (COM1)
  3. I open Rainbow_mtX.pde by arduino-0022
  4. if I want to upload Rainbow_mtX.pde, I get this error message:

Binary sketch size: 3136 bytes (of a 32256 byte maximum)
all the lights go out for 1s
avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x00
avrdude: stk500_initialize(): (a) protocol error, expect=0x14, resp=0x00
avrdude: initialization failed, rc=-1

  • Double check connections and try again, or use -F to override*
  • this check.*
    avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

all the lights go out for 1s

I’ve tried to change the board in arduino-0022, but without success.

do you have a solution? Thanks. PK