[RISOLTO]Chiarimento su transistor npn

Salve a tutti,
come da titolo vorrei dei chiarimenti sull'utilizzo di transistor npn (BC337).

Ho realizzato questo schema:

Il quale prende come ingresso un voltaggio di 12V , ricevuto da una fotocellula,innesca il transistor che fa passare il segnale (+5V) verso un ingrsso digitale di arduino (pin 6).

Il problema è che mi succede una cosa "strana",
se stacco l'alimentazione di arduino e faccio condurre la fotocellula arduino si accende regolarmente o quasi (il LED ON sembra un po' meno brillante).

é normale questo comportamento od ho fatto una ciofeca di interfaccia?

Ciao van.

Fai un grave errore ad inviare delle tensioni ad Arduino mentre è spento, è contro ogni regola, non vedo come Arduino possa accendersi inviando alimentazione ad un suo pin, ma se lo fa non è affatto un buon segno. Il circuito che hai postato è corretto a sta facendo il suo dovere, ma tu devi usarlo come si deve...

Grazie Michele.

NoNo , non invio tensioni ad arduino dal pin 6 , e successo che ho scollegato arduino dall'usb lasciando l'alimetatore esterno
acceso e la fotocellula attiva il risultato e che non si è spento.
Ho spento subito l'alimetatore esterno xchè anche a me pareva molto strano,
comunque ho riprovato il pin (x paura di averlo danneggiato) e funziona tutto.
Ho provato a risimulare l'errore e si è verificato nuovamente.
Bho , "misteri dell'elettronica" !!!

EDIT:Mi sa che devo stare più attento nell'ordine di spegnimento dei device :slight_smile:

Ciao van.

ma l’alimentatore esterno è collegato anche ad Arduino? In questo caso la connessione USB non alimenta nulla, serve solo per il caricamento degli sketch, ed è normale che scollegando solo l’USB lavori tutto. Se invece l’alimentatore è usato SOLO per la fotocellula ribadisco che in questo modo invii tensione all’Arduino spento e fai un errore

se tu stacchi i 5volt dal collettore e lasci i 12 volt sulla base il transistor si comporta come un diodo e sull'emettitore ti ritrovi i 12Volt della base meno cadute di tensione del "semitransistor/diodo" e resistenza... il pin di arduino è fatto per i 5volt però a volte si salva fino a 12 per via di uno zener che ha all'interno.
E' quello che vuoi da questo circuito?

non so se interpreto la tua idea ma io per interfacciare delle fotocellule "industriali" che lavorano a 12 (o più frequentemente a 24v) faccio un semplice partitore di tensione per trasformare i 12v il circa 5volt e ci affianco uno zener 4,7V di sicurezza....questo in particolare quando non posso usare optocoupler.

@Michele : No, arduino è alimetato solo da usb, quindi l'errore c'è stato, ma non c'entra niente con il circuito che volevo realizzare, una svista diciamo.
Con l'alimentatore esterno (che è un ATX modificato) alimento tutto il circuito di interfaccia x la fotocellula (5V-12V).

@qsecofr: Si , è una fotocellula industriale a 12V e il primo progetto l'avevo realizzato con dei optocoupler ma visto che nel circuito finale i 5V della logica vengono ricavati (7805) da i 12V
mi sembrava inutile usare un fotoaccoppiatore (x l'ingobro soprattutto) [ho detto na boiata?]

Ciao van.

no non hai detto una boiata: anche perchè non basta buttarli li senza arte ne parte... almeno 2 resistenze le devi comunque mettere. comunque imho alla fine fai un partitore con 2 resistenze e se trovi uno zener (se no pazienza): costa pure meno.

ciao
intervengo per chiedere se usare un fotoaccoppiatore non dia maggiori garanzie di isolamento tra i due circuiti, permettendo un domani di utilizzare sensori con tensioni differenti ma compatibili con il fotoacc.
stefano

stefa24:
ciao
intervengo per chiedere se usare un fotoaccoppiatore non dia maggiori garanzie di isolamento tra i due circuiti

stefano

è be... l'isolamento è strabuono... Dio se ti scende un fulmine magari ti distrugge il circuito ma ti brucia sicuramente tanto tanto altro...

@qsecofr: Infatti 2 resistenze e pure un led in serie (x lo stato) x l'optocoupler

Mi sa che ritorno su i miei passi e rimetto l'optocoupler, so che il partitore funziona a modo , ma non gli do molta fiducia (nulla di tecnico è "una cosa mia")

Credo di poter mettere risolto.

Ciao e grazie a tutti.

Van.

van4dium:
@qsecofr: Infatti 2 resistenze e pure un led in serie (x lo stato) x l'optocoupler

Mi sa che ritorno su i miei passi e rimetto l'optocoupler, so che il partitore funziona a modo , ma non gli do molta fiducia (nulla di tecnico è "una cosa mia")

Credo di poter mettere risolto.

Ciao e grazie a tutti.

Van.

....be ti capisco... comunque il problema tecnico del partitore di tensione è che se domani mattina decidi di alimentare a 24 volt il partitore bruci arduino... per questo motivo io metto uno zener: casomai ci fosse qualcosa in più questo se lo mangia ed allora ti diventa un po' più sicuro.

van4dium:
Salve a tutti,
come da titolo vorrei dei chiarimenti sull’utilizzo di transistor npn (BC337).

Ho realizzato questo schema:

Il quale prende come ingresso un voltaggio di 12V , ricevuto da una fotocellula,innesca il transistor che fa passare il segnale (+5V) verso un ingrsso digitale di arduino (pin 6).

Il problema è che mi succede una cosa “strana”,
se stacco l’alimentazione di arduino e faccio condurre la fotocellula arduino si accende regolarmente o quasi (il LED ON sembra un po’ meno brillante).

é normale questo comportamento od ho fatto una ciofeca di interfaccia?

Ciao van.

Lo schema non é uno dei piú fortunati.
Se metti il transistore col emettitore a massa e la resistenza R2 tra collettore e +5V allora non hai i problemi che Ti entrano i 12V attraverso il transistore. Il pin di Arduino va attacato al collettore.

Non é mai una buona idea mettere la resistenza o l’ utenza tra emettitore del NPN e massa se si vuole usare il transsitore come interuttore. A seconda della tensione sulla resistenza o sul utenza la tensione sulla base necessaria a portare il transistore in saturazione varia.
Se si mette l’emettitore a massa questo problem non si pone.

Ciao Uwe

Ciao uwe.

Ho provato a seguire il tuo consiglio e ... ok è il normale funzionamento del transistor
però devo "leggere" il segnale invertito giusto? (non è assolutamente un problema , è solo per chiarezza)

Con esempio:

digitalWrite(13,!digitalRead(6));

Ciao van.

Se si da tensione ad un pin dell'Atmega quando l'Atmega è senza alimentazione, la tensione entra nel microcontrollore riuscendo ad alimentare il chip (e la scheda).Ecco perché, come dici, è un grave errore dare tensioni all'Arduino quando la scheda è spenta.

van4dium:
Ciao uwe.

Ho provato a seguire il tuo consiglio e ... ok è il normale funzionamento del transistor
però devo "leggere" il segnale invertito giusto? (non è assolutamente un problema , è solo per chiarezza)
...
Ciao van.

Sí, quando ci sono i 12V il segnele sul Pin di Arduino va a massa percui invertito (ma molto piú sicuro).
Ciao Uwe

Ma avendo la massa in comune (5V regolato da 12V quindi accoppiato x definizione) il foto accoppiatore è inutile, meglio il transistor semplice o sbaglio? (come da schema consigliato da uwe)
Il partitore di tensione , come direbbero dalle mie parti , "Un mi garba per nulla" per questa applicazione.

Ciao van.

Se vuoi isolare i due circuiti piloti il LED del optoisolatore con i 12V ( in serie a una resstenza) e metti il transistore di uscita in serie alla resistenza. In quel caso decidi tu se metterlo tra 5V e resistenza o tra resistenza e massa. Comunque l' emettitore va verso la massa).

Ciao Uwe

Perfetto , ho esaurito le domande (solo sull'argomento :slight_smile: ).

Risolto tutto.

GRAZIE MILLE!!!

van4dium:
Il partitore di tensione , come direbbero dalle mie parti , "Un mi garba per nulla" per questa applicazione.

e perché? cos'è che ti fa vedere tanto male l'uso di due R al posto del tuo circuito che, peraltro, non necessita di alcuna "amplificazione" o "interruzione". Inoltre dal punto di vista della sicurezza è eccellente, viste le bassissime correnti in gioco. Comunque se ti va di fare una prova, ci metti un istante:
tra i 12V ed il pin di Arduino metti una R da 15kohm
tra il pin di Arduino e GND metti una R da 10kohm
I tuoi 12V, se presenti, vengono "magicamente" ridotti a 4,8V; se sono assenti invece è la R da 10kohm che, in funzione di pull-down, mantiene il livello logico del pin su LOW.

Certo che vista così assume tutto un altro aspetto.
La mia paura era che, siccome questo circuito , una volta realizzato non dovrò installarlo io,
potessero accadere errori vari, tipo inversione di polarità o contatti attaccati male ecc...
Ma ripensandoci credo di essermi fatto solo "un bel film in testa", perchè , se invertono l'alimentazione la fotocellula
non va, e se la bruciano non mi importa (tanto la pagano loro) e nel caso che brucino la scheda, meglio, me ne comprano un altra ]:smiley: $).
Stasera passo a comprare le resisenze da 15K? ,provo il tutto e poi faccio sapere (c'è da sapere poco ma per correttezza...).
E se proprio voglio essere sicuro metto un bel diodo tra 12V e GND e mi levo ogni dubbio.

Grazie mille.

Ciao Van.