[Risolto] esp8266 si spegne con Arduino Nano

Buona sera ragazzi, avrei un quesito da esporvi, premetto che ho cercato prima su Google e ho provato a parlare con altri per cercare di capire cosa stia succedendo :P

Sto cercando di collegare il mio Arduino Nano ad una scheda esp8266 per connettermi alla mia rete wifi, ho collegato tutto come da immagine |500x254 e tutto procede come deve, si accende il led piccolo rosso (su esp8266) ma ovviamente non riesco a comunicare con la scheda (esp8266) perché il pin a fianco al TX il "CH_PD" non è nello stato "HIGH" e quindi a quanto ho capito è come se la scheda non fosse abilitata ad eseguire.

Leggendo su vari forum e documentazioni ho visto che va collegato sempre su i 3,3v, quindi aggiungo quest'ultimo collegamento ma PUF! la schedina (esp8266) si spegne, tolgo l'ultima connessione e si riaccende...

Dubbioso, ho provato ad alimentare la schedina esternamente e lasciando collegati solo il TX e RX ad Arduino e Funziona!! riesco ad inviare vari comandi in seriale...

Fiducioso, riprovo ad alimentarla da Arduino, ma niente, stesso problema... Ho provato con la resistenza in serie sul tx di Arduino e a collegare in altri schemi postati online... sempre lo stesso risultato, potrei accontentarmi di alimentarla con un altra fonte, ma preferisco fare tutto il più compatto possibile, mi piaceva l'dea di avere sia i 3,3v che i 5v da Arduino.

Avete Idee o vi servono altre info??

Per la mia "normale" conoscenza mi sembra come se la schedina andasse in sovraccarico, anche perché prima di spegnersi si accende di fianco l'altro led piccolino blu (non vuol dire niente, ma preferisco abbondare d'informazioni).

Grazie Ragazzi e Buona Serata!

Quel 3V3 non fornisce abbastanza corrente per l'ESP, necessita proprio un alimentazione esterna. 3V3 1A va bene.

Grazie busco per la risposta, quindi se volessi collegare il mio Arduino Nano via wifi che scheda mi consigli, lasciando perdere il discorso alimentazione esterna?

>MrTaik: essendo il tuo primo post, nel rispetto del regolamento (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (spiegando bene quali conoscenze hai di elettronica e di programmazione … possibilmente evitando di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO … Grazie.

Guglielmo

P.S.: Qui una serie di link utili, NON necessariamente inerenti alla tua domanda:
- serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections
- pinout delle varie schede by xxxPighi: Pinout
- link generali utili: Link Utili

>busco: Ti prego, prima di rispondere, di verificare sempre se l’utente abbia effettuato la presentazione, cosa che, ovviamente, NON può essere possibile se il suo numero di post è 1. Grazie anticipatamente per la collaborazione. :slight_smile:

MrTaik: DOPO che avrai fatto quanto su richiesto ...

... ti segnalo che in Megatopic c'è un thread di oltre 170 pagine interamente dedicato al ESP8266.

Nella [u]prima pagina[/u] troverai una serie di link a guide e tutorials che quasi sicuramente ti permetteranno di trovare la risposta hai tuoi quesiti.

Guglielmo

Buona Sera anche a te gpb01, la presentazione è stata fatta, il regolamento lo avevo letto ma non avevo fatto caso che continuasse in un altro post.

Burocrazia a parte, ti ringrazio, sono riuscito a collegarlo perfettamente! Quindi la cosa è fattibile!

Domanda rapida un po' off-topic, quindi ora per inviare delle richieste http funziona tutto con i comandi AT... O posso utilizzare qualche libreria come faccio sulla Nodemcu?

Grazie ancora!

Se a qualcuno potrà interessare, ho risolto con la libreria WiFiEsp.

Buon Proseguimento, Sciauusss!!