Second 433 Mhz Remote Not working

Hi all,
Recently started a little project to build a home automated gate. Originally the unit came with a two button 433Mhz EV1527 remote and it's own controller. Threw the controller into the corner and used an arduino to do all the work including a little RF receiver from IOT Store rrf-receiver-module-433mhz. Managed to get it connected to the remote and the first remote works just fine.

Noticed that the reciever would assign to D3 first, then D0. Not sure why but it seems to always do that with whatever button I press first. Not exactly sure if D1 or D2 will come next and there doesn't seem to be any documentation confirming this.

Decided to buy a second remote as a spare/for when someone inevitably loses one of the remotes. Supposedly it was exact same design 433Mhz EV1527 and it certainly appears all but the same internally (link to spare remote). Tried to connect it up so that I have 4 separate outputs from the receiver (remote 1 open/close and remote 2 open/close). When I tried this it seemed to program everything as a separate input however remote 1 Open and remote 2 open appear to have the exact same signal and activate the same channel. Not an issue as I can work with that. Remote 1 close works and activates the right channel however Remote 2 close doesn't appear to respond. It will say it's programmed but when you try and push the button to test its functionality it will flash the light on the receiver as though it's receiving a valid signal but nothing happens. Tried changing the order I program in to see if it's a dodgy receiver output and it makes no difference. It seems to not have actually programmed and has programmed the next button after it onto that channel.

At quite a loss as to why this could be happening. I know the code works to detect the output (not exactly rocket science with a HIGH = on, LOW = off and all the button coding is handled internally by the receiver). Even tried connecting an LED up to it and it still does the same things. Only thing I thought of was that the second remote needed cloning however I can't seem to get it to clone and am not sure if this is even the right solution.

Any suggestions would be much appreciated.