SelfMade Arduino Nano clone stops responding after Nicks Bootloader install

Hello,

I have run Nick Gammons Fuse Calculator.
I have run Nicks Board Programmer and after it fails, it stops responding at all.

@Nick:
I thought my chip is dead and I changed it with new one.
It opens programming mode and after a while it aborts.
Problems come after I run the Board Programmer with a try to write a bootloader (Uno).

Posible Errors (new):
New Fuse settings during the attempt to write the bootloader.
Maybe setup to external Crystal-and mine is defective.

Can somebody please take a look on the Shema if I made a mistake somewhere?
Nick, any Ideas?

Thanks

Nothing jumps out at me. Should post the layout too.

Have you ohm'ed it out to check for shorts? Check all adjacent pins, particularly those used for programming, ensuring that they're not shorted to ground, supply, or eachother. Shorts underneath a capacitor are fairly common.

The schematic shows the "reset capacitor" between the FT232 and GND. That's wrong. Your 328 pinout looks wrong; RX and TX are on PORTD, not PORTC. (However, Neither of those explains your immediate problem.)

DTR should go thru the cap then connect to Reset.

Ditto onPD0, PD1, those are the D0/D1 Rx/Tx pins (I might have them swapped).

Think you also need to connect Test on Ft232 to Gnd, check the datasheet.

Hi,

Thank You very much.

I changed the DTR output to Reset. Corrected the RX/TX Ports and connected Test to GND.

I checked the PCB Layout manually. The only difference between my standard design is the "missing" C5 Cap. On this layout I relocated C5 far away from Pin18. Usually I put it near the µC Pin. Can this cause my Problems?

I'll fix this. If it works I'll make new PCB and post the results.

Thanks again, Mav.

Hello,

The new Circuit.

Programming over ISP working now. Not over USB.
On Nicks FuseCalculator I get this:

Atmega fuse calculator.
Written by Nick Gammon.
Version 1.10
Compiled on Jul 20 2015 at 20:29:30 with Arduino IDE 10604.
Attempting to enter programming mode ...
Entered programming mode OK.
Signature = 0x1E 0x95 0x0F 
Processor = ATmega328P
Flash memory size = 32768
LFuse = 0xFF 
HFuse = 0xDA 
EFuse = 0xFD 
Lock byte = 0xFF 
Clock calibration = 0xAB 
External Reset Disable.................. [ ]
Debug Wire Enable....................... [ ]
Enable Serial (ICSP) Programming........ [X]
Watchdog Timer Always On................ [ ]
Preserve EEPROM through chip erase...... [ ]
Boot into bootloader.................... [X]
Divide clock by 8....................... [ ]
Clock output............................ [ ]
Bootloader size: 2048 bytes.
Start-up time: SUT0: [ ]  SUT1: [ ] (see datasheet)
Clock source: low-power crystal.
Brownout detection at: 2.7V.

As I was not sure why my previuos Boards doesnt responds after I run Nicks Programmer,
this time I burn the (Nano) Bootloader directly with my Uno over the IDE.

When I plug in the Board, there is a Handshake between the Computer and the Nano.

The serial Chip get 4,75V over USB.
Is this enought?

On Abort I get this:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x28

Regards,
Mav

Uno fuses:

uno.bootloader.low_fuses=0xff << same for both
uno.bootloader.high_fuses=0xde << DE vs DA, low 3 bits 110 vs 010. Bits 2-1 set boot size
11 = 128 words, 01 = 512 words.
uno.bootloader.extended_fuses=0x05 << low 3 bits match, xxxxx101, sets brown out level.

I think the high fuse byte needs to change so the bootloader starts at the correct place.

The Atmega seems working. The Serial Interface make me problems.

Do You think I should change the fuse?

Can't hurt.

I have changed it. Nothing changed on the behaviour of the board :(

I have got 3 FTDI Chips left to try with.

Ill try to monitor the USB I/O.

Hi,

I noticed something strange today. As You maybe noticed, I made 2 Setups. One with 32U4 and another with 328P-AU and the FTDI Serial Interface.

Uploading over USB on 32U4 needs manual RESET till the "Upload" message appears. This is known problem on the Leonardo boards. I also need this Upload procedure under the Micro bootloader.

Now, the strange one. The Board under Nano (or UNO) bootloader behaves the same like the leonardo. The only difference is the timing for pressing the reset Button. While on the Leonardo I have to press it till the Upload message comes on the Nano i have to press it once at the same time when I press upload on the computer.

I tried on different USB I/Os and different Computers. Both was unter Win7.

I never heared something similar. Any Ideas?

Sounds like on the 328P design you do not have DTR from FTDI going thru a 0.1uF cap to the Reset pin, with a 10K pullup on the Reset pin to +5. That would allow the PC software to reset the 328P chip. Hence the need to press reset manually to get the bootloader started.

EDIT: OK, I misunderstood something.
I’ll add this R10K to the Reset PIN of the FTDI.

@CrossRoads: OK, to pull-up the reset on the FT232 doenst help.

Do You know if external FT232 needs manual Reset too?

The 10K pullup needs to be the 328P reset pin. See attached.

The 10K pullup needs to be the 328P reset pin

I have got this one in all my Setups, like You.

It's strange that I get the same problem on 2 different Boards (328P and 32U4)