Serial port greyed out

Hi,

Hope this is the right forum for my question.
I have formatted my harddisk of my iMac pc.
I reinstalled Arduino and the ESP8266 library.
When I try to upload the code to the Arduino, the serial ports are greyed out.
I have used several USB cables, but nothing works.
I hope somebody can give me some help how to procedure.
Thank you in advance.
Yvonne

Do your USB ports work when you plug in a USB flash drive?

Yes. It can read a USB flash drive.
I run OS High Sierra.
I have installed ch340g-ch34g-ch34x-mac-os-x-driver (GitHub - adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver: CH340G CH34G CH34X Mac OS X driver).
But no success.
Thanks for your reaction.

I don't have a Mac and cannot provide further ideas.

Problem solved finally.
I installed the SiLabsUSBDriver and followed the instructions.
It works: /dev/cu.slab_USBtoUART.
Hopefully this will help somebody else as well.

Yvonne

Silicon Labs make their own chip which is a competitor to the CH340.

Not sure why you need it unless you are using a USB to TTL adapter.

.