Serial port is greyed out

Hi, I'm using a MacBook Air with an M1 chip, and when I plug in my arduino uno, the serial ports are greyed out. I've seen that other people have had this problem but none of the solutions I saw worked for me. When I plug the card in the green lights is on and the orange light starts blinking. I've tried installing some FTDI drivers, selecting an other type of card, and I tried it on an other mac (with an intel chip), with the same result.

It's an official arduino, I got it in the arduino starter kit, and the usb cable is from there to.

I'm really new to arduino, so I don't know much about it and I just hope I'll be able to use my card soon.

Thanks in advance.

Did you try a different USB cable? Many of those cables, nowadays, are power only.

1 Like

The cable was given in the kit so I think it should normally work. Do you think it could be the hub ? I tried two different owns with the same result...

I do not know anything about the Mac, sorry. There is a connection troubleshooting page that may help or do a Google search for "arduino grayed serial mac". From what I read, it is probably a driver installation problem.

1 Like

Thank you for answering ! I've finally solved the problem by changing hubs. Seems like the one I was using had a problem.