Serial Port not selected

Hello folks, I am new in this forum

Previous activities: NIBOburger hardware + tests OK.

Software Done: Run niborobolib 302-0_x64.msi t Drivers and programs stored under C:\Programme(x86)\Arduino....

Opened https://www.arduino.cc and download Windows Installer for Windows XP and up . arduino-1.8.8-windows.exe

Open ICON Arduino anklicken. Window shows scetch_jan31a | Arduino 1.8.8

under tools - selected board nicai systems NIBO burger robot and under tools selected NIBObee & buger programmeer (usbasp) BUT tools – Port is pale and no selection

Verify Done compiling Bootloader file specified but missing: C:\Program Files (x86)\Arduino\hardware\nicai\avr\bootloaders\DoNotEraseTheBootloader (this may be only a warning) Sketch uses 5316 bytes (32%) of program storage space. Maximum is 16384 bytes. Global variables use 211 bytes of dynamic memory.

Serial port not selected.

Windows 8.2

Thanks for help NIBOtoni / Anton

Do you see any new device appear in Device Manager after you plug the USB cable of your NIBOburger board into your computer?

If you are using an external programmer (NIBObee & buger programmeer (usbasp) ?) then you don't need to select a serial port. You use Sketch>Upload Using Programmer instead of the normal Upload button.

pert: Do you see any new device appear in Device Manager after you plug the USB cable of your NIBOburger board into your computer?

Yes Pert, the device Maqnager has a new entry

libusb-win32 devices NIBO robot

But - sorry, the port in tools should show even without plug in - or?

BJHenry: If you are using an external programmer (NIBObee & buger programmeer (usbasp) ?) then you don't need to select a serial port. You use Sketch>Upload Using Programmer instead of the normal Upload button.

Hi BJHenry

when I

after succesful Done compiling

use Sketch - Upload using Programmer Ctrl+Shift+U this mesages are displayed:

Bootloader file specified but missing: C:\Program Files (x86)\Arduino\hardware\nicai\avr\bootloaders\DoNotEraseTheBootloader Sketch uses 5316 bytes (32%) of program storage space. Maximum is 16384 bytes. Global variables use 211 bytes of dynamic memory. Error while uploading: missing 'program.tool' configuration parameter Invalid library found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_jan29a: no headers files (.h) found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_jan29a Invalid library found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_sketch_jan29a: no headers files (.h) found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_sketch_jan29a Invalid library found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_jan29a: no headers files (.h) found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_jan29a Invalid library found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_sketch_jan29a: no headers files (.h) found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_sketch_jan29a Invalid library found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_jan29a: no headers files (.h) found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_jan29a Invalid library found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_sketch_jan29a: no headers files (.h) found in C:\Users\Anton\Documents\Arduino\libraries\erster_sketch_sketch_jan29a

It looks like you are storing your sketches in the library folder. Don't do that. Copy them to a different location, delete the sketches from the library folder then try again. Make sure the have the IDE closed when you do the copy/delete process.