Setting up DUE problems.

I have 1.8.12 IDE installed and I can upload sketches from the IDE to an Arduino UNO rev3.

I'm trying to set up a new Arduino DUE. First the DUE was not on the board list. From this site I read that the DUE could be added by running the Board Manager utility. I 'installed' the DUE and now it appears in a separate box at the bottom and there are 3 choices with only two being active. Arduino DUE (Native USB Port) and Arduino DUE (Programming Port)

In the picture below it shows the board being an UNO with a port connection. When I select from the DUE box at the bottom then the port selections goes dead grey. I have exhausted my limited knowledge.


OldRon: there are 3 choices with only two being active. Arduino DUE (Native USB Port) and Arduino DUE (Programming Port)

This is normal and expected. Each platform has its own section in the Tools > Board menu. The "Arduino ARM (32-bits) Boards" is the title for that section. It's not a board, thus it would be wrong to make it selectable.

OldRon: the port selections goes dead grey.

Make sure the USB cable is completely plugged into both the Arduino board and the PC.

You may have a damaged/defective or charge-only USB cable. Try a different cable.


Thank you for your input. It was indeed the cable. I suspect that some cables for items such as a cell phone are charge only and I was using my cell phone cable. Just as soon as I switched cables the PC acknowledged discovery of new hardware connection. I had an Arduino UNO rev3 with IDE v1.8.12 working prior to the Arduino DUE. With the DUE the IDE couldn't find LiquidCrystal_IC2.h whereas the UNO had no problem. It doesn't make any sense but I changed the order of the includes and that resolved that problem.


You're welcome. I'm glad to hear it's working now!

The situation with LiquidCrystal_IC2.h does indeed seem strange. It sounds like you already have found a workaround for it, but if you end up getting blocked by the same sort of issue later feel free to post about it here on the forum. I'm sure we'll be able to help find a solution.

Regards, Per


I setup the library when I started with the Arduino UNO rev3 and that is why it worked. I assumed that the library was global but after a dozen+ errors stating that the file, LiquidCrystal_IC2.h could not be located I ran the library install with the Arduino DUE connected. My sketch uploaded and my text was on the display. Oh well, I got the Keypad right in one try.

Looking back it seems so simple but it sure gave my patience a good work out. Thank you for letting me cry on your shoulder.