[SOLVED} China ST7735 Not Displaying

China ST7735 ST7735 was purchases last week.
I have tried numerous libraries and test code wihtout any luck.
Markings on the back of the TFT are KMR144_SPI V2
Pins on the back are: and connected to Uno:
VCC 3.3V
GND GND
CS D10
RST D9
RS D8
SDI D11
CLK D13
LED 3.3V

Using the Basic TFT library from Arduino, and setting the correct pins, it displays a grey background but no text or images. The Serial Monitor shows the data being displayed so the code is ruuning.
Does anyone have one of these displays and has managed to get it to work.
I have tried ADAFruit ST7735 Library as well as TFT_ILI9163C
Thanks in advance

Update: I found some code to help identify the TFT (Identify_TFT attached). This comes back with the following:
Bi-directional Read registers
controller reg(0x01) = 0x00
ILI9163C reg(0x04) = 0xFFFFFF
ILI9163C reg(0x09) = 0xFFFFFFFF
ILI9163C reg(0x0A) = 0xFF
ILI9163C reg(0x0B) = 0xFF
ILI9163C reg(0x0C) = 0xFF
ILI9163C reg(0x0D) = 0xFF
ILI9163C reg(0x0E) = 0xFF
ILI9163C reg(0x0F) = 0xFF
ILI9163C reg(0x2E) = 0xFFFFFF
ILI9163C reg(0xDA) = 0x54
ILI9163C reg(0xDB) = 0x80
ILI9163C reg(0xDC) = 0x66

Which I would assume identifies the chip as ILI9163C. So if I use sumotoy library and Test I still get a grey screen. It is backlit but no text or lines displaying?

Identify_TFT.ino (4.21 KB)

If you are using an UNO or 5V Arduino then the display needs logic level converters.

The display will not work unless the logic levels are 3.3V compatible.

See the post here.

Thanks Bodmer, I bought some more logic level converters. It appears one of mine was dead. Thanks for the info.

Regards Q