s'print-S taxi receipt thermal printer with Arduino

Another alternative to the adafruit printer with a similar issue - but I don’t need to undertake an authoring of a whole new library for my task.
Printing a graphic of data stored on a flash chip attached to the arduino.
Alas, I am not supporting the hard work on open source code by buying adafruit products…but have several old cheap/free thermal printers and got two working. I may need to ultimately drive the thermal head directly, but will need to monitor the control lines while it is correctly functioning before that stage.
The model is Custom s’print-S
can print fine from pc - but tried Serial.write() and can’t get a string or graphics, just garbage. Nicely printed though.
Sending control codes as in attached ‘similar’ model datasheet .
Is responding to serial input, so seems unlikely TTL/true(whatever up to 25v± according to Wiki!)RS232 mismatch.
checked connections and upload by monitoring output on input RX pin of TTL/USB adaptor and LED’s blink as expected.
As was found in the previous thread, the datasheets can be brief and confusing - am I missing additional control codes to actually print the buffer out or something? Does do a line feed though after the garbage. Made up a PNP transistor/PP3 battery TTLtoRS232 voltage level translator. Checked circuit worked as required with multimeter.The Printer circuit board has an ST202 RS232 converter chip - but the main thing I hadn’t taken account of is the byte bits are inverted without conversion. Still garbage with following code but now variable length lines of mainly UPARROW symbol.

Cannot paste code formatted for forum without embedded javascript colour coding getting pasted as well, so there is no point because it is unreadable.
Is this a website scripting problem?

s’Print Manual.pdf (2.35 MB)

yes , well - nice javascript error on that code paste. had glitches on Arduino website all this morning. ha ha. will post modified later when hopefully things are sorted out.