This Program Requires

at least Java Development Kit 1.5.0…
This is after I downloaded Arduino 1.0.5 R2 and 1.5.6R2. installing 1.5.6 went fine but the 1.0.5r2 installation gives me this message when I attempt to open the 1.05 IDE “This program requires at least Java Development Kit 1.5.0”…
What to do? or what did I do wrong.
The box is a Samsung NP-N150 Notebook with an Intel Atom processor with 1 GB of Ram…
What to do?.. I’m lost as 1.5.6 seems to work OK

Doc

You should install Java Development Kit 1.5 or later. Usually automatic java install is for JRE (Java Runtime Environment) and not for JDK.

Try to download JDK 1.5 or later and restart IDE. You can find JDK here
http://www.oracle.com/technetwork/java/javase/downloads/index.html?ssSourceSiteId=otnjp