TMC2209 SilentStepStick various problems

I am currently trying to make a motorised camera slider (from some cannibalised 3D-printer parts).

I bought a SilentStepStick TMC2209 from WatteRot (along with the protector V2).

The Stepper motor I am using is a NEMA14, 0.48A, 200steps/rev motor.

Currently I am using a Teensy3.2 as a controller; I wanted to test the circuit with a 3.3V microcontroller as I plan on getting one of the new Arduino Nano 33 BLE's.

Eventually I plan on running this of standard camera batteries (7.4V), but for development I am using a lab bench power supply.

However I am having a lot of troubles getting things to work properly...

At first I could not get the motor spinning, but after a lot of fidgeting with the tiny potentiometer on the module, I got the motor spinning. To me at least, it seems to be spinning at a normal rate. However the motor is really anaemic, I can really easily stop the motor, by applying just a little finger pressure...

I don't know if this is normal, but the little potentiometer is also really "twitchy" if I turn it even the slightest bit the motor won't turn at all anymore. I then have to rotate it all the way one way and then go back really slowly until I find the exact position that will allow the motor to spin.

Also the power supply shows that only +- 90mA is being drawn, The power is not drawn from the USB-port either as that is showing a current of +- 60mA. I thought that the 7.4V wasn't enough to get proper results, as most 3D-printers run on 12V or 24V volts. But setting these values on the power supply did not change the current, leading me to suspect that the stepper driver is kinda doing what it is supposed to do?

After taking a look at the datasheet, I found out that there is a configurator (over UART) where you can set various parameters, including the motor current.

I dug up my Arduino USB to serial converter and connected it according to the datasheet Link to datasheet page.
I installed and opened the configurator. Whenever I tried to open the serial connection, I kept getting CRC errors and failed connection. After trying various times, it would eventually connect, without any apparent reason or difference. Just deciding that it was the right time.

But I used the configurator to set the motor current (it was 400mA, I believe not wanting to overdo it right away), I then disconnected the UART bridge and reconnected the Teensy (with a simple step/dir program), but no difference....

I reconnected the UART and bridge and after once again trying various times, got it connected eventually. But it showed all the default values, instead of the ones I had set. Even though it says that all changes are written right away, they don't seem to persist beyond a power cycle... But the changes are written right away, because the Rx/Tx lights flash everytime I make a change, and when pushing the read back button, it shows my chances.

Some final remarks:

  • Neither the driver nor the motor get hot; The driver with its heatsink even feels cold to the touch
  • Yes I have checked all the connections / common ground etc
  • The configuration pins don't seem to be doing anything
  • The motor does run really quiet!

So at this point I am really puzzled and confused.
I have no idea how to continue, or if these things are normal at all, I have looked all over the internet and this forum...

If anyone here has any ideas and tips on how to proceed, it would be greatly appreciated! Also sorry if I forgot to mention any information, I tried to be as complete as I can!