Unable to upload to Arduino Duemilanove

My first attempt to upload a example sketch to the board was successful. My second attempt was to upload the loop sketch and connect a leds to Digital pins 1-7. Since this attempt the upload hangs with the TX led constantly flashing. The program hangs and I loose control functions, I have to make a forced closure of the program.

I removed the external bench top power supply and leds connected to digital outputs. Powered the board via the usb connection. Attempted to upload the 'loop" file, I get a constant flashing "TX" led and the program hangs? >:(

I hooked the board up to a laptop. The errors that I received,

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x20

when connected to the laptop, it appears that you need to choose a different port. I had that problem when I first started with mine. With the USB cable disconnected, you should see the available ports in the menu. When you Arduino is connected, you can go back to the menu and see another port that wasn't there before. This is the port you want to connect to.

I am having an identical problem with my new Duemilanove. I have not been able to upload anything. I have confirmed via the LED test in pin 13 that there is a Bootloader on my chip. When I try to upload anything, I receive identical error messages. I know this is not an issue of port as I also have a Diecimila and am connecting to the new model via the same port.

First i made my Arduino S3V.3R.2 Board (Single sided PCB)

I think quality is ok for DIY board...

My PC is intel dualcore 3GHz, 8Gt RAM WinXP Pro x64-SP2, and arduino sw is 0015.

sketch i tried is one digital examples -> blink.

Problem is in communicating with PC-SW between board, i have tested 3 diffrent PCs and i alway get same error...

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

i have programmed my ATmega8s with AVRStudio 4 with STK500. when ATmega8 is clear no blink after reset, but after programming LED 13 blinks after reset. So i assume programming is OK.

i used this http://www.brunonadeau.com/howto/ArduinoBootloader/ how-to.

i have googled error message but have not found solution to my problem.

yours

Thank you all... for kind support.

OK it works now...what i made?

  1. i cleaned my registers just in case.

  2. C:\arduino-0015\hardware\programmers.txt i added lines for my STK500 witch have FW2

STK-500

avrisp.name=STK-500 avrisp.communication=serial avrisp.protocol=stk500v2

  1. i erased my boards with AVR Studio4.16 and STK-500.

  2. i started Arduino 0015 and burn bootloader in arduino way with STK-500 :)

  3. NOW IAM PLAYing with it... :)

yours