Upgraded to 1.8.2. Now libraries not working

I'm sure this is going to have an easy answer, but after a full day of trying, it is still eluding me. :confused:

I have been using IDE version 1.0.2. I recently upgraded to 1.8.2, and none of my sketchs will compile now. It is saying files like i2cdev.h cannot be found.

I have copied the file into practically every directory. I have also used the "add file". Nothing I do will work. I can open the same project in the old version and it works fine. Where am I supposed to be putting the files so the IDE sees them?


It is saying files like i2cdev.h cannot be found.

Files like i2cdev.h or always that file?

And what is that file exactly? It's not part of the new or old IDE at least.

wow nevermind. I just got it. I had to redownload the zip file and add the zip library. It added the same file, but apparently wanted to be done that way.

I2cdev and ads1115 is for using the ads1115 chip with arduino.

You should always install libraries to {sketchbook folder}/libraries, which is all that Sketch > Include library > Add .ZIP library does. The location of the sketchbook folder is set at File > Preferences > Sketchbook location. So the file should be somewhere like this:
{sketchbook folder}/libraries/i2cdev/i2cdev.h
Note that each library folder should be directly under the libraries folder, not in a subfolder:
{sketchbook folder}/libraries/i2cdev-master/i2cdev/i2cdev.h
{sketchbook folder}/libraries/i2cdev.h
will not work
If there is a library.properties file in the root of the library folder then the source files can be placed in a subfolder named src:
{sketchbook folder}/libraries/i2cdev/src/i2cdev.h
This is know as the Arduino 1.5 Library format and is not backwards compatible with Arduino IDE 1.0.x: