Uploading Error

I am having trouble uploading my program to the Arduino board.
I have the Arduino/Genuino Uno board with the software version 1.6.9.
The board has been selected on the program as 'Arduino/Genuino UNO' and the port " COM4".
The port has been checked and it is ok, the driver is installed,selected manually and up to date.
Whenever I am uploading the file, the RX will blink for 3 times then will stop and LED13 will continue blinking normally.
The error message shown is the below:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xa8

...This will continue up tp attempt 10 of 10.

Will be really glad if someone can assist me as this is my first time using the program and controller.

Thanks.

Dan

Try the Loopback Test at the top of this forum. Doesn't sound like the Atmega16U2 USB/Serial adapter is talking to the PC.

I open the loopback test and connected the jumpers as said but I didn’t really understand these 3 steps…how can I do this on Windows 7, is it in the cmd ?

"6. Start your favourite terminal application. Serial Monitor will work fine.

  1. Connect the terminal application to the serial port for your board. The baud rate is irrelevant.

  2. Send data by typing. Everything you type should be echoed back. To send data, some terminal applications, like Serial Monitor, require pressing the Enter key or clicking a Send button. If exactly what you send is echoed back then the board passes the test. This means that the host computer hardware driver, USB cable, and USB to serial converter are all working."

Thank you for your help

You can do it in the IDE's Serial Monitor.

I used the IDE's Serial Monitor and typed digitalWrite(9,HIGH); but nothing happened and there was no echo back. The test was just showing down when I press enter. Any text I was typing was showing down on the screen.
Then I disconnected the controller and tried to send again the program but still same problem.

Ok so I tried the loop-back test again and all is working.
The Serial MOnitor is echoing everything I type…
But still till now I am not being able to upload the program.
Same faults are still showing

Sounds like perhaps a bad board. You may try seeing if it works with another computer and with a different USB cable. That's what I would do before contacting the seller.

Hmmm...I tried with a different USB cable that I know it's already working but still nothing.
Will try with a different PC to see if the problem remains the same.

Thanks guys

Guys

I tried uploading a program on a different pc and I still got the same issues.
I went through all the troubleshooting procedures but still not being able to upload.
Could it be from the board itself?

Thanks

Yes, most likely a bad board. If it is newly purchased I suggest contacting the seller for a replacement if possible. If they do not require you to return the bad one, mark it bad and store it for future parts salvage or repair once you are no longer a beginner. I'm sorry to hear you are having such troubles just getting started.

smiley-confuse: I also like your error, you have a solution yet?
Please share with me, thank you

well I've been trying to troubleshoot it for the past 4 days but up till now I still can't get the issue.
I will just contact the supplier and request another board as it is newly purchased...
Thank for your help guys, much appreciated.