Uploading problem

New to all this Bought a "Freetronics" experimenter kit (equivalent to an Arduino Uno.) Computer is Asus eee PC running Windows XP - (Chrome Browser)

Downloaded the USB Driver ver 2.2, unzipped and ran it. Plugged Uno into PC and checked in Device Driver - showed device by name and on COM 4 Downloaded the Arduino IDE for Windows. Set the Tools>Serial Port to COM4 (ticked)

Tools>serial port shows a list of ports with COM4 ticked regardless of whether the board is connected to the PC or not. Is this correct?

Hooked up the LED and dropping resistor for the sketch "blink" - it blinks Tried to amend the sketch to change the blink timing and then tried to upload the new timing - NIL

Nothing I have tried enables me to change the blink rate.

The upload result includes details of the space used/available then:

"avrdude: usbdev_open(): did not find any USBdevice "usb"

So I read the troubleshooting advice, shut down bluetooth and tried the Loop Back Test as per the instructions on this site - failed. Nothing written was echoed.

So it seems Device Manager is recognising and reporting the Arduino's presence correctly but I am not able to communicate with the Arduino IDE.

Any hep appreciated please.

Which version of IDE?

Think you need to ask the Freetronics folks about the 8U2 driver they are distributing if loopback test is not working.

Arduino 1.6.3 according to the page header.

i recommened to use 1.0.5 or 1.0.6 version of IDE.

you can download here http://arduino.cc/en/Main/OldSoftwareReleases

Thanks for the suggestion. Would you mind telling me why? As a true newbie I need to understand why the older software will fix this problem please MiloT

The software has bugs ; its under fixing software bugs.So if you check all forum who is using 1.6.xx or 1.5.xx version your are facing problems.

Thanks. Loaded Ver 1.0.6 Still not able to upload. Getting error message "avrdude: ser_send(): write error Sorry no info avail.

Suggestions most welcome. MiloT

In that case u need to ask you need to ask the Freetronics folks about the 8U2 driver . else you will get avr pocket programmer . once you uploader it might start working

For continued discussion http://forum.freetronics.com/viewtopic.php?f=9&t=6239