usb2.0-serial

Hi to all at arduino

just wondering if any one can help.
i have an uno r3 and a nano pro.
the uno works great no probs, connects, uploads. really happy with it.

but when i plug the nano in to xp sp2 pc via usb, it finds new hardware but wont install the drivers. i cant find these usb 2.0-serial drivers anywhere. iv tried re-installing the ftdi drivers from arduino site but the comm port still does not show up in the ide and i still have usb 2.0-serial flagged up in device manager.

again, if any ones got the answer please help.

many thanks

Have you tried www.ftdichip.com? http://www.ftdichip.com/Drivers/D2XX.htm or http://www.ftdichip.com/Drivers/VCP.htm

yeah i have the drivers. my uno works ok. the first time i plugged it in i installed the driver and away we went. this time with the nano i pluged it in. it asks for usb 2.0-serial drivers. i dont seem to have any files/drivers that will satisfy the needs of the 'found new hardware' window so i cancel that and then run the ftdi driver. ( the one i ran for the uno) it installs without a glitch (again) but the developer still cant see the nano and the system still wants some usb 2.0 - serial driver.

Post a link to where you got the nano from. Some clones use a different usb to serial chip.

Hi, I had he same error on windows 7 (USB2.0-serial driver not installed). I bought the arduino nano from banggood for 3$ (http://www.banggood.com/ATmega328P-Arduino-Compatible-Nano-V3-Improved-Version-With-USB-Cable-p-933647.html)

solution was to take the CH340G driver for windows (http://www.arduined.eu/ch340g-converter-windows-7-driver-download/)

Download the archive then run the installer in the CH341SER drawer.

Works well !

Cheers 8) .

I’m having the same problem with my Uno and Windows XP sp2 machine running IDE v 1.6.1. I’ve tried reinstalling FTDI drivers but still no luck. Everything works as it should on my Linux machine. Any advice would be appreciated.

Thanks,
Tim

Open a terminal window. run dmesg. Plug the board in. Run dmesg again. Note what driver it loads on Linux.

Go find the correct driver for Windows.

Alternatively.... Just use Linux. It works.

had same problem. Thanks guys for advice. I am now working again

I have solved with this drivers...

http://www.wch.cn/download/CH341SER_ZIP.html

bye bye

Thanks CrossRoads, your second link solved this issue for me. I have a seven year old notebook running Vista that I had earmarked as my Arduino-dedicated machine. I had all but given up on using it because I was having NO success getting it to communicate. Now I can get on with the REAL fun! :o)

HELO! HERE IS THE SOLUTION!!!

<<<<

Thanks!!! doubts: thiagogoncalves25@hotmail.com

:slight_smile:

Thanks, everyone !
I was having the same problem with a banggood Nano and my XP laptop, the CH341 driver from wch.cn fixed it.

thanks. my problem same to. work with CH341SER.ZIP.

Thank you VitAngelo

Thanks, all. CH341SER_ZIP worked (Windows 10, 64 bit)

Thanks it's working perfectly... :)

Its work :) :) http://www.wch.cn/download/CH341SER_EXE.html

hi all.. i have the same board, i have the drivers installed, and the Arduino program sees the COM ok,, i have the Arduino Nano board selected...but i do not know which programmer to select..

any advice? i can't down load anything to it.. keep getting errors..

update...

i do have the drivers installed for the CH340G chip and the Arduino program does see the device connected.

it shows as connected to COM6.. but i can't download anything to it, and error code comes up as not being able to connect to COM8

can you advise what i need to do so that i can get it to communicate ?

does Arduino only want to see FTDI devices and not any of the CH340G devices.? i need to know soon before i return these units as JUNK. (frustrated here )

This helped a lot, thanks!