USBASP Clone on Windows 10 x64 Not working

Hello,

I bought this usbasp from China, since it has positive reviews i thought it was good to go.

Now I'm using Windows 10 x64, I did install all propper libusb-win32-bin-1.2.6.0 drivers with the help of the provided Inf-wizard tool and downloaded Zadig. It seems all drivers are correctly installed with the inf wizard, it shows as expected in the Device Manager as Usbasp with an exclamation mark. O far so good this is what Zadig should tackle.

But then, as advised I put the usbasp in an USB 2.0 port and i get an error message from Windows The Device has stopped "Unknown USB device (Device Descriptor Request Failed)"

Now I have the USBASP listed in device manager under the libusb-win32 and libusbK Usb Devices. But also under the Universal Bus Controllers, I have the "Unknown USB device (Device Descriptor Request Failed)".

Zadig only sees this Unknown USB device and is not able to install drivers.. It simply is not recognized as a USBASP.

I tried several workarounds to resolve the issue from a Windows perspective to no avail... I asked a question at the vendor's website and the answer given is "Maybe this USBASP isn't W10 X64 compatible." Disable unsigned drivers didn't do it and installing it in compatibility mode also failed.

I can not imagine that I'm the only one on W10 x64 who wants to play with AVRprogrammers. I had similar errors and issues with a Digispark, but this I resolved with the correct drivers from micronucleus, but this again requires a bootloader with another isp changing the fuses. I would like to program my chip default without a loader at 1Mhz. Currently, I'm using the ESP8266 AVRISP, for now, the only one I got properly working on this machine. But also this has its glitches now and then.

Everybody says using a USBASP is much more convenient but not for me I get a runaround that seems impossible to solve.

Now my questions are... Did anybody had the same issue with USBASP on W10 x64 and was able to resolve this? And if not can someone please point me to a USBASP that definitively is W10 compatible?

Thanks in advance... :slight_smile:

panyvino:
a USBASP that definitively is W10 compatible?

https://www.google.com/search?q=how+to+install+drivers+usbasp+windows+10

rtek1000:
USBASP Installation in Windows 10 : 8 Steps - Instructables

how to install drivers usbasp windows 10 - Google Search

Thanks for the reply, I did all steps required as described… Windows and Zadig only see an Unknown USB device with error code 43. Windows says Best driver already installed, Zadig says Failed to install the driver. It seems this USBASP I have does not register in the system as a USBASP.
One thing I yet didn’t try is flash the USBASP with a different firmware… But then I have to see if I get this working with ESP AVRISP… If I need another USBASP for that I would need one that works in Windows 10 x64 that I yet don’t have. Then it’s back to square one.

See if this tip works:

Mine is installed this way:

USBasp.png

USBasp.png

rtek1000:
See if this tip works:

USBasp & Windows 10 | The bright side

Mine is installed this way:

USBasp.png

Thanks for your reply... This doesn't work either...
Mine doesn't install at all and shows up like this in device manager.

This is also what the Zadig installer sees, but it fails to install a driver... I've tried about every workaround I can find about this error and nothing solves it...
I actually had the very same error lately with a clone from the Digispark AVR development board for ATTiny and the only way to solve it was to install a bootloader to the chip with the ESP AVRISP first to get Windows to recognize it as a valid USB device and install the proper Micronucleus and Digispark drivers.
This gives me the hunch that this USBASP probably has corrupted or outdated firmware that needs to be reflashed. For now, I'm at the end of what I can try other than flashing another firmware to it.
Anyway, thansk again for your time...

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.