USBtinyISP not working

Arduino: 1.8.9 (Windows 10), Board: "ATmega328, No bootloader, EEPROM not retained, 328PB, BOD 2.7V, LTO disabled, Internal 8 MHz"

C:\Users\e_cha\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino18/bin/avrdude -CC:\Users\e_cha\AppData\Local\Arduino15\packages\MiniCore\hardware\avr\2.1.2/avrdude.conf -v -patmega328pb -cusbtiny -e -Ulock:w:0x3f:m -Uefuse:w:0b11110101:m -Uhfuse:w:0b11011111:m -Ulfuse:w:0xe2:m 

avrdude: Version 6.3-20201216
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Users\e_cha\AppData\Local\Arduino15\packages\MiniCore\hardware\avr\2.1.2/avrdude.conf"

         Using Port                    : usb
         Using Programmer              : usbtiny
avrdude: usbdev_open(): Found USBtinyISP, bus:device: bus-0:\\.\libusb0-0001--0x1781-0x0c9f
         AVR Part                      : ATmega328PB
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00

         Programmer Type : USBtiny
         Description     : USBtiny simple USB programmer, http://www.ladyada.net/make/usbtinyisp/
avrdude: programmer operation not supported

avrdude: Using SCK period of 10 usec
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.

Error while burning bootloader.

New USBTinyISP, it's giving the same error message whether I have it connected to a chip being programmed or not. Has ATTiny2313 and I've downloaded driver from Adafruit. Can anyone tell me what the error code means? And before anyone tells me to upgrade Arduino IDE, any version newer than 1.8.9 does not work with ATTiny10 core at all.

You say you are using an attiny10, but you have selected a 328PB based board!

Show your wiring, and tell us what chip you are trying to program!

my wiring:


(I need to fix the green wire's damaged insulation. No short, this is just a prototype and I'd do better with later designs)

ISP pin 1 (marked by 1) is connected to pin 16 (MISO), pin 2 to 4 and 18 (VCC) with decoupling caps to ground, pin 3 to pin 17 (SCK), pin 4 to pin 15 (MOSI), pin 5 to pin 29 (reset, with 10k pullup to 5v), and pin 6 to ground pour.

If I connected this board to UNO and used Arduino as ISP, I can program it just fine. It's the USBtinyISP that is not connecting for some reason.

I am trying to program 328pb and I am using the right chip (as it worked with UNO as ISP). The Attiny10 was just an excuse to keep using older IDE 1.8.9 because the core didn't work on newer IDE. I posted about this: ATTiny10 does not work with IDE 1.8.10 or newer, only with 1.8.9 or older - #5 by wilykat and never got any answer after the final posts

I upscaled your image as much as possible, it may be mistakes by my ai but I believe you may have more damaged insulation beyond that one spot on the green wire. Can you verify this?

What type of solder are you using and at what temp?

5 connections are not enough for ISP programming!
VCC
GND
RESET
MISO
MOSI
SCK

You're looking at the wrong port. There is a 2x3 pad labeled ISP and I mentioned I can use UNO as ISP to program this. USBtinyISP is the one not working

If you're using the ISP connection how are you connecting them? They look untouched to me.
The picture you have shown shows wires but you are not programming via those wires?

There is nothing soldered to the ISP pads! I assumed you had soldered the wires to the programming header!, please show your wiring, and describe how you are connecting the programmer to the ISP header without solder!