Using Arduino Uno(clone) as ISP to burn bootloader to another Arduino Uno(clone)

Hi all,

I know there are a number of posts on this matter here but none seem to resolve my issue.

I am using Uno clones but I get the same error when using an official Arduino Uno.

The error is:

"avrdude: Device signature = 0x000000 avrdude: Yikes! Invalid device signature. Double check connections and try again, or use -F to override this check."

I have successfully uploaded the ArduinoISP sketch to the uno I will use as a programmer. I have wired up the two uno's using the diagram supplied by Arduino. The only difference is that I am using a 100uF cap between GND and RES as I don't have a 10uF cap. I have also installed the LED lights following the sketch description.

I have "Arduino Uno" selected as the board. I have "wchusbserial1d10" selected as the Port. I have "Arduino as ISP" selected as the programmer.

The arduino's have AmtelMEGA328P

I have rewired the configuration a number of times and receive the same error (on both the official and the clone uno) when I click tools>burn bootloader.

Note, both these unos (the ones I am trying to burn the bootloader to) give the error "avrdude not in sync" when I try to upload sketches. hence my reason for trying to burn the bootloader.

Any help would be appreciated. Thanks.

This error means that there is no response from the programmed board, it is not connected or improperly connected. The first advice is in the error message: "Double check connection". Provide picture or photo of your setup.

Sorry for the delay. Here is a photo (attached is better quality). I am sure they are wired correctly. The green led “heartbeat” shows the programmer is running, the error seems to occur after clicking “burn bootloader” and when the programmer and slave start communicating (yellow led lights up and error outputs).

Hard to say now, the setup looks ok. Make sure whether the wires are good. You can switch on verbose output during upload in preferences to obtain more detailed log. Anyway, the zeros in responses means that there is no answer from target. Try to check all electrical parameters on target with e.g. DMM: Vcc, reset signal - there should be visible negative pulse on it prior to programming, etc.