Which chip is this: "ATmega328P U"? [SOLVED]

On my UNO the chip is labeled “ATmega328P-PU”, and I ordered some of those for stand alone projects. The ones I got are labeled “ATmega328P U”, and if I put one of them into the UNO, they appear to be perfectly interchangeable.

However, I want to change the bootloader to run on the internal 8MHz clock but it seems like I cannot burn the bootloader to the new chips. I have followed this guide but the procedure fails and the output I get is:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt X of 10: not in sync: resp=0x00

Where X increases from 1 to 10.

So… Where’s the skunk burried…? :slight_smile:

EDIT: Solved, read post #8

atmega328.jpg
P U above P-PU

Select "Arduino as ISP" from Tools > Programmer (emphasis added)

Are you sure that you chose the right programmer in the Tools, Programmer menu?

Yep, did everything exactely as the guide says. Even tried both of the cirquits in the guide - but no cigar!

Can you post a photo of your setup? How to post an image.

From this Instructable:

I learnt the hard way that there is more than one type of ATmega328. The two variants that are of interest to us are the ATmega328-PU and the ATmega328P-PU.

The -PU suffix means that the chips are in a PDIP package, the format we need for our breadboard.

The 328P is a picoPower processor, designed for low power consumption, and is used on the Arduino boards. Given low power consumption this is first choice.

The 328 does not have picoPower technology, and is not used on the Arduino boards – and is not explicitly supported by the Arduino IDE.

What this means is that we can easily bootload the ATmega328P, but not the ATmega328. Unfortunately the websites that sell these chips don't always differentiate between them and forums are filled with people struggling to use the ATmega328-PU.

ATmega328P U

So if the processor that you are trying to bootload is the NON-P (not pico power) chip then it is not compatible with the IDE.

I use the MiniCore core to bootload those chips. After they are bootloaded with MiniCore you need to select the right chip in the Tools, Boards menu for programming.

@groundFungus: Thank you for your answers! I’ve already found that info but I am just not certain what the actual type of MCU I’ve got is. I bought my MCU’s from here and according to the seller these are original 328P-PU, but the ones I received differs both from the sellers picture and from the original MCU in my UNO. Now I just found this link which looks more or less exactely like the MCU’s I’ve got and they are also sold as original 328P-PU, even though the image says 328P U.

I really hope someone can take a stand of wheter it’s a new print or some fake chips.

P.S: Another link I’ve just found is this one and as soon as possible I’ll try to see what the “Atmega_Board_Detector” says about the MCU’s! :slight_smile:

I guess Microchip has removed the package code from the marking.

avrdude: stk500_recv(): programmer is not responding

The error you are getting is from BEFORE the chip type is checked, so there is probably some error in the way you have loaded the "Arduino as ISP" sketch into your "programmer" Arduino.
try following This Tutorial instead; it's generally better written, more recent, and more correct than the arduino.cc tutorial (which still doesn't mention bypass capacitors, despite YEARS worth of comments that they should be added. Sigh.)

Short story: The MCU's are legit 328P and the problem was caused by a faulty dupond/jumper wire.

I looked at your suggestions and tried the Gammon guide, the Gammon programmer sketch, the Gammon board info sketch but nothing worked. It seemed like the MCU's where completely dead when placed on a breadboard. So I cloned my setup with a new breadboard, new MCU, new caps, new wires, new oscillator/chrystal and so on and with the cloned version everything worked as it should. I started to investigate the old setup but I could not find anything wrong with it - except that it didn't work. By (dumb) luck I used some of the jumper wires in another project and one of the status LED's had a weird flickering and that was when I found out that one of the jumper wires worked if bend one way but if bend the other way it didn't. The jumper was the one used for grounding in the first "arduino on breadboard" setup, so that was the culprit.

Thanks to everyone, karma scattered :slight_smile:

Are they the common “Arduino kit” jumper wires with round rubber collars where the wire meets the round metal pin? If so, throw all of them in the bin, they are absolute junk. Cut one apart and you’ll see. The wire is few strands of hair like thickness and I don’t know for sure if the wire is even soldered to the pin or if the design relies on the collar to hold the wire in contact with the pin.

The “DuPont” rainbow cable jumpers are okay but the the best jumpers for breadboards is plain old #22 awg solid wire.

Thank you! Now I know problem is microcontroller because identical things happened to me. So, i 'll get new chip with ATMEGA328P-PU label.

I'm using the Atmega328P U and it works fine. I was able to swap the one in the UNO and it worked exactly the same. No issues with the IDE.