Why doesn't the Arduino IDE install the needed USB COM port driver?

I installed the Arduino IDE today and ended up with the "FT232R USB UART" driver, listed in Device Manager under "Other devices". This didn't allow me to select a COM port from the IDE. I then found the 38 page FTDI document which says how to install the correct driver, which takes two further installations.

After the next installation, I had the "USB Serial Port" driver listed under "Other devices". I then did another installation and got the "USB Serial Port (COM3)" driver under "Ports (COM & LPT)". This is what I needed -- I can now upload code to my Arduino Nano.

My question is: Why doesn't the Arduino IDE installation take care of this and install the correct USB COM Port driver in the correct location under "Ports (COM & LPT)"? During the IDE installation, I clicked "Install" on 3 different USB-related installation dialogs. Yet, when the IDE installation was all done, I didn't have a usable USB COM Port driver, and had to do the additional installation steps described above (preceded by a LOT of Googling to figure out what I needed to do).

Again, my question is: Why doesn't the Arduino IDE installation just take care of all of this??

Thanks for your thoughts on this.

How did you install the IDE?

from https://www.arduino.cc/en/Guide/Windows

(I'm on a Mac, there was no need for drivers except for some non arduino products)

To install the IDE, I downloaded and executed arduino-1.8.15-windows.exe. I believe this file then downloads other files.

During the IDE installation process, I clicked "Install" when prompted by dialogs from these drivers:

  • Adafruit Industries LLC Ports(COM & LPT...
  • Arduino USB driver with a Publisher of "Arduino srl"
  • Arduino USB driver with a Publisher of "Arduino LLC"

I would think, after the installation is done, I would have a USB COM port driver and wouldn't need to go to the FTDI website to download another driver along with a 38 page driver installation manual.

BTW, based on my Googling, not having the USB COM port driver available after the IDE installation is done appears to be a common problem (that's why FTDI makes their driver available). I just don't understand why the Arduino IDE installation can't take care of this.

OK.... a good alternative is to use Linux or macOS :slight_smile:

The FTDI device is NOT the only UART serial to USB adapter used by Arduinos, or Arduino clones.

Furthermore, these devices and their drivers change frequently, as do Windows versions, so it does not make sense to expect the Arduino IDE installation to do everything for you.

If the IDE does not want to install a USB COM port driver, then it should warn the user that the installation process is incomplete and they may need to find/install certain additional drivers. Right now, the IDE silently performs an incomplete installation, forcing the user to start searching for how to complete it.

It seems like there should be an IDE installation dialog that says something like: "The Arduino IDE installation is complete except for the USB COM port driver. To install the USB COM port driver, read this document...[give URL]".

Perhaps a more general statement is needed along with a pointer to a more general document, but having the IDE installation silently fail isn't the right answer. Arduino should reference SOME document that describes what might be incomplete and how to possibly address the issue(s). Such a document should certainly cover the USB COM port issue. Right now, the recommendations are quite generic and of limited usefulness, like "Try rebooting your PC if the IDE doesn't work".

BTW, in addition to all of the people "out there" who appear to have this same problem, the Arduino IDE installation has failed (due to the missing USB COM Port driver) on 2 of 3 computers I've tried it on.

may be no one is using Windows anymore as a development machine and it was not tested :slight_smile:

I was under the impression that the FTDI VCP driver came pre-installed on Windows.

The whole "FTDI-gate" drama centered around a new version of that driver rolled out via a Windows update. That's the only time I've ever had to think about the driver. I know that there is a copy of the driver in the drivers subfolder of the Arduino IDE installation. It's a very outdated version, which might be related to your problem.

Which Arduino device do you have?
Which version of windows do you have?

If the IDE is counting on the FTDI drivers already being present in windows, then its subject to the whims of windows and maybe FTDI, and maybe "local security policies" whether it's actually there.

when the IDE installation was all done, I didn't have a usable USB COM Port driver

Nonsense. You had several USB COM port drivers, just (apparently) not one that worked with the actual Arduino board that you have :frowning:
(There is no single "USB Com Port Driver" - there is a separate driver for each possible USB/Serial hardware. One for the 16u2 chip on an Uno, one for the 32u4 direct USB, one for the ch340 used on many clones, one for the cp2102 used on some other clones, one for FTDI (maybe more than one; FTDI makes several chips, etc...)