Why my library invisible?

I put my custom library to arduino libraries folder with src folder which contains the .h and .cpp files, and keywords and library text file (I'm not so sure about the last 2 if those are correct or not), but I cannot see it in the arduino IDE so I cannot install, I cannot #include it because it says: No such file or directory. What to do and how can I put my library in it?

Did you restart the Arduino program ?

Yes, of course but nothing happened.

Well, another angle: if you include your library in a sketch, does it compile? If so - no problem. Right?

What is the name of your library, what is the name of the folder that the src folder is in and what are the exact names of your .h and .cpp files ?

It cannot complie becuse it said a fatal error occured (the header is missing)

All of that has the same name

If you put the same library files (i.e. .h & .c) in the same folder as your sketch and you include the .h file with double quotes (") instead of angle brackets (<>), do you get the same error?

OK, but what exactly is the name ?

Please post the .cpp and .h files here

It’s like an easter egg hunt.

Well I don't know what is this sorcery but it worked.. Thanks

Also, I had to add the .h and .cpp files to sketch to get the "" include working

What exactly do you mean by this and why don't you answer the questions about the name and location of the library ?