Wifi Shield WebServer Example not Loading

Hi, I have the arduino wifi shield and I was trying the example code from here(the WifiWebServer example in the IDE):http://arduino.cc/en/Tutorial/WiFiWebServer. But when I run it, it connects to the network but then when I try to connect to it from a browser, firefox says:

Unable to connect

Firefox can't establish a connection to the server at 192.168.1.46.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer's network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Here is all that the arduino puts out on the serial monitor: Attempting to connect to SSID: ***** SSID: ***** IP Address: 192.168.1.46 signal strength (RSSI):-55 dBm

Any ideas? All help is appreciated. Thanks in advance, Luketheduke

Have you upgraded the wifi shield firmware? Here is a way to check it.

  // check for the presence of the shield:
  if (WiFi.status() == WL_NO_SHIELD) {
    Serial.println("WiFi shield not present"); 
    // don't continue:
    while(true);
  } 

  Serial.print("Firmware version: ");
  Serial.println(WiFi.firmwareVersion());

It should report 1.1.0 if upgraded, and 1.0.0 if not.

It says 1.0.0 I am trying to upgrade it now....

It outputted when I executed this command in command prompt(windows 7) from http://arduino.cc/en/Hacking/WiFiShieldFirmwareUpgrading Parsing ELF File ...... can't open input file "file location(shortened)\wifi_dnld.elf Any ideas? It seems like it has already erased the device so I guess I just crossed the Rubicon...

I got the same message. You should still be ok.

I moved both those files to my root directory instead of that long path. It worked from there.

I followed Ludgy's guide and it worked first try. http://forum.arduino.cc/index.php?PHPSESSID=0g864usaihcj5af5uckifaso93&topic=180445.0 Thanks for all your help SurferTim! Thanks, Luketheduke