Hi everyone,

I recently got a WTV020-SD-mini sound module and as hard as I try I cannot get it working. I have followed the datasheet here: http://www.emartee.com/product/41540/MP3%20Sound%20Module%20Mini%20SD%20Card

I have had audio playing using the button control method, so my files are working and playable. I just cant figure out how to get it to accept serial control.

I have also been using the SOMO-14D resources out there to see if that helps.

I am pretty confident in the code as it is similar to: http://yapan.googlecode.com/svn/trunk/arduino/examples/SOMO_14D_Test/SOMO_14D_Test.pde and that worked for this chip for people.

I think my issue may be more hardware; IE: knowing how to get this chip into serial mode.

Has anyone had any success with it using with its serial and an Arduino? If so, I'm wondering: - how you wired it? - how you coded it?

Thanks for any info guys! Cheers, Dan

From your link:

WTV020-SD voice module adopts WTV020SD-20S as core procesing chip. It supports MP3 control mode, key control models (3-voice and 5-voice),pwer control mode or two-line serial control mode . Control mode is set while producing, which can not be changed through configuring.

Note: please choose the mo3 mode you want to order and we will ship for you as you order!

So, unless you got the serial mode version, it doesn’t look to me like you can get it into serial mode.

On the other hand there is this:

If you want to control the mp3 player with serial port commands with arduino, first you must put the cof.mp3 file with number 1 inside the advert1 folder.

Have you created this file, in this directory? Does the file contain just the number 1?

I definitely got the serial version. I emailed them at first and asked and they said that it is (and actually sent me a second one to make sure). As for the folder/file structure I have tried both that way and the 0001.ad4, 0002.ad4 methods.

I have also looked through some arduino wave stuff. I'm pretty sure it's a hardware issue. Has no one used one of these before?

Its got me baffled too.

Hardwired as MP3 mode When I trigger pin 9 , all I get is a beep. I tried several wav files, and even reconfigured those wav files to ensure they had the proper bit rate. I tried the sample ad4 files found in this forum, and then tried mp3s. I'm using a 1Gb scandisk SD card.

Simply 3.3V into VDD pin 16, an LED with 500 ohm resistor to pin 15, pin 8 wired to COM. Tie pin 9 to ground to trigger. Get nothing but a short beep. The LED does go out while it beeps. I'm using a cell phone speaker - the chip doesnt drive a 1/4 W speaker. The chip doesnt play files at all from memory.

Wonder what I'm doing wrong ................not sure what to ask the vendor.

I fixed my problem by loading .ad4 files to the SD card. The .mp3s needed first convertered to mono and 6kHz .wav files, then to .ad4s. Sounds sweet

Sorry for a silly question:

Are you using this module? : http://www.sparkfun.com/products/11125