AD8232 Single Hearth Rate monitor board

Buongiorno, Ho comprato recentemente una scheda AD8232 da SparkFun (https://www.sparkfun.com/products/12650) ma sto avendo un'infinità di problemi con essa.... volevo quindi chiedere se qui dentro qualcuno ha già avuto modo di utilizzarla con successo e quindi se sarebbe così gentile da potermi aiutare. Grazie

Hai seguito il loro tutorial ? https://learn.sparkfun.com/tutorials/ad8232-heart-rate-monitor-hookup-guide

>DeltaElectronics: in conformità al REGOLAMENTO, punto 13, il cross-posting è proibito ([u]anche tra lingue diverse[/u]) e tu hai posto la stessa domanda anche nell'area di lingua Inglese.

La cosa NON è amessa ed il post (... segnalato hai moderatori dagli utenti di quell'area appunto per cross-post) è stato quindi cancellato. Ti prego quindi di continuare qui e di NON duplicare i tuoi post nelle varie aree del forum. Grazie.

Guglielmo

... in merito ad eventuali "problemi", ricorda comunque che stai parlando di una "schedina giocattolo" da 20US$ e NON di uno "strumento elettromedicale" quindi, un oggetto con tutte le limitazioni del caso, addatto più a fare piccole prove in casa che cose più serie ed il sito lo specifica bene:

Note: This product is NOT a medical device and is not intended to be used as such or as an accessory to such nor diagnose or treat any conditions.

Comunque, ciò premesso, che tipo di problemi stai riscontrando?

Guglielmo

@Guglielmo... Sì, ha ragione ho fatto cross post, ma questo allo scopo per cercare di poter trovare più persone, anche non in lingua italiana, che potesse aiutarmi a risolvere questo problema. Me ne scuso e pagherò le eventuali conseguenze. Venendo al problema, semplicemente è dando tensione alla scheda (3,3V, alimentata da board Arduino UNO), riscontro un comportamento del tutto anomale ed imprevedibile, in quanto il LED a volte si accende, altre rimane spento, oppure improvvisamente da spento ritorna acceso e così via.... a volte muovo la scheda ed il LED si accende, oppure si spegne etc. etc. Questo sia inserendo i jack a freddo, oppure a scheda accesa, oppure a jack nemmeno inseriti. E' vero che si sta parlando di un prodotto da 20$, però credo che con quella cifra si potrebbe già pretendere un comportamento (pressapoco) affidabile e comunque prevedibile, non crede ? Grazie per l'aiuto. DeltaElectronics

DeltaElectronics: Venendo al problema, semplicemente è dando tensione alla scheda (3,3V, alimentata da board Arduino UNO), riscontro un comportamento del tutto anomale ed imprevedibile, in quanto il LED a volte si accende, altre rimane spento, oppure improvvisamente da spento ritorna acceso e così via.... a volte muovo la scheda ed il LED si accende, oppure si spegne etc. etc.

Mmm ...quello non dovrebbe accadere e, la descrizione, mi da l'idea veramente di un qulche falso contatto o saldatura fredda ... verificate bene le saldature?

Eviterei anche collegamenti volanti con "jumper" (spesso inaffidabili) o quant'altro ... magari un alimentazione dedicata a 3.3V con la massa in comune con quella di Arduno ... ::)

Una foto del tutto ?

Guglielmo

@delta io ho quel modulino. Ma funziona a 3,3V NON a 5V, non solo come alimentazione ma soprattutto per tutti i segnali. Devi usare un altro modulino che faccia da traslatore di TUTTI i segnali da 5V a 3,3V
Io ho un Sparkfun Level Converter (quello rosso).
Oppure usi una Arduino Mini Pro a 3,3V
Inoltre alimento il modulino da 5V con in mezzo un modulino (blu) che abbassa la tensione a 3,3V perchè dai 3,3V di Arduino escono pochi ampere. Tutte cose spiegate nel tutorial di Sparkfun

PICT3730.JPG

@gpb01: probabilmente saranno le saldature... ma a questo punto devo aspettare di ritornare a casa perché qua non ho la lente e preferisco chiedere l'aiuto ad una persona più esperta di me. Non credo siano dei falsi contatti per il semplice fatto che il tester mi da sempre 3.3V tra il morsetto 3.3V e GND, sia a LED spento che a LED acceso. Certo che lo stesso problema si verifica su ben due schede (dello stesso fornitore).

@nid69ita: infatti la alimento a 3.3V (verificati anche con il tester)

Grazie per l'aiuto

DeltaElectronics: @nid69ita: infatti la alimento a 3.3V (verificati anche con il tester)

Occhio che Nid ti segnalava che NON basta alimentare a 3.3V .. occorre anche inserire i traslatori di livello su tutti gli I/O visto che Arduino lavora a 5V mentre quella scheda vuole i 3.3V anche sugli I/O ;)

Guglielmo

gpb01: Occhio che Nid ti segnalava che NON basta alimentare a 3.3V .. occorre anche inserire i traslatori di livello su tutti gli I/O visto che Arduino lavora a 5V mentre quella scheda vuole i 3.3V anche sugli I/O ;)

Guglielmo

Ringrazio anche @Nid.... probabilmente mi sono spiegato male: La prova che ho fatto non è con Arduino UNO, ma ho semplicemente alimentato la scheda in questione con un modulo USB ft232rl.2362 in modo da generare i 3.3V; collegandola ho riscontrato le anomalie sopra riportate. Volevo quindi chiedere, sopratutto a @Nid il perché di tale comportamento e a cosa potrebbe essere dovuto. Thanks

Ma i GND li hai messi in comune ?

nid69ita: Ma i GND li hai messi in comune ?

C'è solo un GND... ed è sopra il 3.3V vedo poi un SDN (negato) che sinceramente non ho capito la sua funzione.

Continuo a non capire. 1. Stai usando un Arduino ? Quale ? Collegare il modulo solo ad un qualcosa che lo alimenta senza un Arduino dietro non sò che comportamento può avere il led, e non ne capisco il senso. Inoltre il modulo deve lavorare a 3,3V ma DEVE anche essere alimentato da un tot di mAmpere. Dal pin 3.3V di Arduino Uno gli ampere sono pochi per quel modulo. Da dove fai tu la prova (ft232rl.2362 ?? ), che ne sò quanti ampere fornisce ?

  1. Se alimenti il modulino a 3,3V ma i segnali arrivano da un Arduino a 5V NON va bene, anche i segnali DEVONO essere TUTTI a 3,3V (come detto in precedenza)

  2. Se usi un Arduino per i segnali e alimenti il modulo da ALTRA fonte, comunque il GND DEVE essere messo in comune. Parliamo di 3,3Volt, tensione elettrica, meglio detta come "differenza di potenziale elettrico" e quindi una differenza tra GND (unico) e Vcc

Nessun Arduino, per il momento.... ho solo alimentato la scheda e volevo vedere l'uscita analogica sul mio oscilloscopio. Comunque in casa ho un Arduino Mini (a 3,3V); domattina proverò con questo.

Salve,
Ho provato (finalmente >:( ) a diagrammare l’uscita analogica della mia scheda ed questo è uno screenshot di quanto ottenuto sul mio oscilloscopio…
Che ne pensa ?
Pensavo di misurare il battito cardiaco contando gli ‘spikes’ che si susseguono quasi regolarmente a circa 600 ms; come potrei fare ?
Potresti suggerirmi un metodo ?
Grazie infinite.
PS: volevo chiedere a cosa servono i segnali di uscita LO+ e LO-
La tensione 3.3V non è affatto un problema; uso proprio un Arduino Mini alimentato a questa tensione.

Mi spiace di non poter aiutare, ma sono un programmatore professionista ma un hobbista per quel che riguarda l'elettronica. Io il modulino e l'ho solo provato con lo sketch di sparkfun collegato a Processing. So che comunicano via seriale ma non conosco il segnale che si mandano (il come si, via seriale ma cosa sono quei valori non lo so) Sorry, igor

Poi essendo un programmatore, ho messo una lcd shield (non ricordo quanti pollici) su una arduino mega e ho messo lo sketch che disegna direttamente su lcd. Ma non ricordo bene se usai il programma di sparkfun adattato o adattando uno sketch trovato su internet. Se ti interessa lo cerco a casa e te lo posto.

DeltaElectronics:

PS: volevo chiedere a cosa servono i segnali di uscita LO+ e LO-

Sono semplicemente i segnali di errore che il chip ti da quando uno o piu elettrodi si scollegano durante la misura (Lead-Off)