Alimentatore 12V

Ragazzi ho trovato un alimentatore in casa e ho provato ad usarlo per alimentare arduino...mi da qualche problema e allora sono andato a cercare le caratteristiche su internet e ho trovato questo...

http://docs-europe.electrocomponents.com/webdocs/0f60/0900766b80f602f8.pdf

Ora quello che ho io da in uscita 12V 2,5A ma ha un ripple di 120mV che a me sembra una enormità possibile che sia quella la fonte di problemi???

non dovrebbe darti grossi problemi...... certo è che 120mV di ripple non son proprio pochi... se puoi metterci in parallelo un condensatore lo abbassi però... più grosso è il condensatore più il riple diminuisce.. se vuoi ti do anche le formule da fare per trovarlo...

Se riesci a passarmele volentieri…Grazie

Non servono formule. 2.5A sono un'ottima corrente per circuiti di prova. Il ripple residuo di 120mV (con che corrente assorbita??? A vuoto? Al Max assorbimento? In quest'ultimo caso è ottimo) non è da strapparsi i capelli e siccome io non mi fido delle dichiarazioni (ne ho buon motivo) lo misurerei. Tanto più che la tabella è alquanto sospetta...

Cmq sono seghe mentali. Vedo dalle dimensioni che è uno switching, e probabilmente destinato ad alimentare un Monitor LCD o un PC portatile, quindi (se funziona correttamente) non ci sono problemi di sorta.

Ma che problemi hai, precisamente?

Beh, non credo sia attrezzato per misurare il ripple, diversamente non avrebbe aperto il Topic, nel senso che avrebbe le competenze sufficienti per sbrogliarsela da solo.
120mV=0,12V se li ha davvero (ma certo sarebbe da capire in che condizione) gli potrebbero dare parecchio fastidio con i pin analogici.

Il ripple indicato nei dati tecnici del Alimentatore é inteso a pieno carico ossia quando da 2,5A alla seguente condizione:

Note (*): Measured with by-pass capacitors 0.1uF//10uf at output connector terminal and oscilloscope set at 20MHz.

Quel rippple non é un problema per Arduino perché ha uno stabilizzatore 5V ne per motori o led alimentate. Non farti problemi dove non ci sono. Ciao Uwe

Ciao Uwe, forse bisognerebbe specificare meglio; io mi riferisco al fatto che se usasse quei 12V come fonte di alimentazione di qualche sensore analogico funzionante a 12V, secondo me avrebbe problemi con le letture analogiche, quindi non parlavo dei 5V ottenuti dallo stabilizzatore interno ma dei 12V usati direttamente. Leggo che tu ti riferisci esclusivamente a carichi, ma il modo in cui dici di non farsi problemi forse potrebbe indurlo in errore, sempre se ciò che affermo io sia corretto, poi potrei sbagliarmi.

@menniti 120mV é un valore normale per un alimentatore switching. Fammi un esempio di un sensore alimentato a 12V Ciao Uwe

Il riple c'è in tutti gli alimentatori DC, quello switching ha il "vantaggio" che il riple residuo è alla frequenza di commutazione dello switching, che di solito si aggira sui 50 o più Khz. Si, può dare delle noie a seconda del circuito che alimenti, ma è impossibile fare un'elenco di quali sono questi circuiti.

Per abbattere il riple, si può ricorrere a stabilizzatori lineari e/o usando filtri LC. Anche usando L e C di qualità standard si riescono facilmente ad ottenere riple di 1-10 mVpp, che non sono nocivi per nessun circuito.

Come dice uwe, Arduino ha un suo stabilizzatore lineare in più ci sono dei condensatori che abbassano il riple e l'impedenza vista dal circuito sotto alimentazione. Nel caso di acquisizioni analogiche il riple eccessivo può dare delle letture oscillanti, ma non è il caso di Arduino per il motivo detto prima.

Nota che una lettura oscillante può essere dovuta anche ad azionamenti di carichi in regime discontinuo, che sporcano la 5 volts stabbilizzata da arduino, per risolvere si devono usare dei condensatori su questi carichi o ancora megli dei filtri LC.

Ciao.

uwefed: @menniti 120mV é un valore normale per un alimentatore switching. Fammi un esempio di un sensore alimentato a 12V Ciao Uwe

Certo, mica ho detto che è "anormale", io sensori a 12V non ne ho mai usati, ho letto di tanto in tanto qualcosa, credo, potrei sbagliarmi, ma il punto che sto evidenziando non è questo; il punto è se questo ripple è in grado di infastidire o meno l'ADC, che poi non lo si usi è un altro discorso; ancora non mi state dicendo se 120mV di ripple possono falsare una lettura ADC a bassi valori.

Ciao menniti Se misuri i 12V abbassandoli con un partitore resistivo puoi avere una lettura instabile di ca 10 ADC. E`da vedere (non ho controllato) se i sensori che Google elenca hanno una tensione di uscita analogica prodotta con un partitore resistivo dove una delle 2 resistenze é variabile dalla grandezza di misura. Ciao Uwe

Grazie ragazzi...io problemi che ho sono un po particolari e difficili da spiegare...in pratica volevo usare l'alimentatore a 12V per alimentare una schedina con dei rele e l'arduino...(ho fatto un po di conti sulle correnti e 2.5A sono sufficienti)...

La situazione è questa... collego l'alimentatore alla schedina rele e nel momento in cui vado a collegare la massa di arduino con quella della schedina si prende una scossettina...tento di spigarmi meglio...Schedina rele alimentata con l'alimentatore,arduino collegato con l'usb al pc e quindi alimentato da li, in questo caso andando a toccare la massa della schedina e la massa di arduino si sente corrente(in alternata tra l'altro)...quello che mi chiedo io è come sia possibile che toccando la massa di due circuiti indipendenti l'uno dall'altro si possa sentire una scossa...

Questo è il problema principale...dopo di che (secondo me per questo problema qui) è saltato in aria un transistor...

@ Uwe: ok, grazie.

@ paolo: forse dovresti postare lo schema elettrico delle connessioni che hai effettuato, ciò che racconti indica chiaramente degli errori, non insistere perché ci rimetti l'Arduino.

Con gli switching puo' capitare, e l'alimentatore del PC e' anch'esso switching, quindi tu ne stai usando due. controlla se la presa di corrente a cui e' attaccato il PC ha il cavo di terra.

Devi verificare che: Tra la presa centrale della spina (GND) ed il negativo di uscita dell'alimentatore ci sia continuità, sempre chè il tuo alimentatore abbia la spina con tre poli.

Poi dipende, è una scossettina? o vedi uno scintillio connettendo l'usb ad arduino.

Alcuni alimentatori per pc portatili non hanno alcun riferimento alla massa GND, potrebbe essere questa la causa. Comuque questo non dovrebbe crerare guasti. Ho usato il condizionale perchè potrebbe essere che in casa tua il pozzetto di terra funzioni male, o che il tuo pc ha l'alimentatore in dispersione, o altro.

Dovresti provare a misuare la differeza di potenziale tra gnd del PC e alimentatore 12Volts, per avere scossettina dovrebbe essere sopra i 60 volts.

Ciao.

@no testato mi ha preceduto

Dovresti provare a misuare la differeza di potenziale tra gnd del PC e alimentatore 12Volts, per avere scossettina dovrebbe essere sopra i 60 volts.

Gia fatto...misuro 115V alternati... Gli alimentatori hanno entrambi una spina tripolare (sia quello da 12V che quello del mio portatile)...e entrambe le prese dovrebbero avere il filo di terra cmq controllo dopo pranzo...Dici che puo succedere???PErò anche collegando i pin di arduino vedo uno scintillio...LA cosa nn mi tranquillizza molto...Nel caso in cui io alimenti arduino e la scheda con lo stesso alimentatore nn dovrebbe piu succedere???

@ paolo: forse dovresti postare lo schema elettrico delle connessioni che hai effettuato, ciò che racconti indica chiaramente degli errori, non insistere perché ci rimetti l'Arduino.

Lo schema per il controllo dei rele è il piu semplice possibile : un transistor NPN con la base collegata al pin di arduino attraverso un partitore di tensione con una R da 220 e una da 1K...l'avvolgimento del relè è collegato al collettore del transistor con un diodo in antiparallelo...il transistor è un classico BC337 che regge fino a 800mA come corrente di collettore...Da datasheet l'avvolgimento del rele assorbe 20mA circa..come ultima cosa l'emettitore del transistor è a massa

Intanto puoi aumentare il partitore a 1K (R di base) e 4k7-10K (R di pull-down), ti serve molta meno corrente per alimentare il 337.
A questo punto credo che qualche problema sulla terra tu lo abbia, 115V significa un bilanciamento totale, comunque controlla.
Io alimenterei, come tu dici, Arduino con l’alimentatore esterno, questo ti scollega automaticamente la tensione della USB e ti unifica le masse, secondo me risolvi il problema delle scintille, ma prima verifica bene l’impianto di terra, altrimenti va a finire che gli spari l’alternata ad Arduino.

quindi devo controllare che la terra nelle prese sia correttamente collegata???Ma per quale motivo succede una cosa del genere???qualcuno me lo sa spiegare???

No, devi controllare se la messa a terra sta scaricando regolarmente. Metti il tester su misura Volt AC Misura tra i due estremi del cavo alimentazione che stai usando per l'alimentatore, dovresti avere circa 220Vac Misura ora tra il centrale del cavo (terra) ed ogunono dei due laterali, in un caso dovresti avere una tensione prossima a 0V (in questo caso il laterale è il neutro), nell'altro una tensione prossima a 220Vac (in questo caso il laterale è la fase). Se questa situazione non ce l'hai allora hai un problema sull'impianto di terra; se invece è OK allora è quello che ti hanno già spiegato riguardo gli alimentatori switching, ma in questo caso alimenta anche Arduino con l'alimentatore a 12V, tramite la presa jack japan e vedrai che tutto si normalizza.