arduino 1.5.1r2 on windows vista

Has anyone been able to run the 1.5.1r2 ide on vista? I understand that it is still beta and might have a few bugs but when i try to run it i get a launch4j dialog with the message "An error occurred while starting the application." all the time. I have no issues with 1.0.

Any help would be highly appreciated.

Deleting the preferences.text from this path C:\Users<User>\AppData\Roaming\Arduino d8id nothing. I still encountered the same error.
Below is the contents of the launch4j.log file after running D:\arduino-1.5.1r2\arduino.exe --l4j-debug from the command line.

CmdLine: D:\arduino-1.5.1r2\arduino.exe --l4j-debug
WOW64: no
Working dir: D:\arduino-1.5.1r2.
Bundled JRE: java
Check launcher: D:\arduino-1.5.1r2\java\bin\javaw.exe (OK)
Add classpath: lib\pde.jar
Add classpath: lib\core.jar
Add classpath: lib\jna.jar
Add classpath: lib\ecj.jar
Add classpath: lib\RXTXcomm.jar
Launcher: D:\arduino-1.5.1r2\java\bin\javaw.exe
Launcher args: -Xms128m -Xmx128m -classpath “lib;D:\arduino-1.5.1r2\java\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar” processing.app.Base
Args length: 158/32768 chars

This is the content of output.txt when i run arduino.exe -Xms128m -Xmx128m -classpath “lib;D:\arduino-1.5.1r2\java\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar” processing.app.Base > output.txt from the command line.

TargetPlatform: constructor start, name: avr
TargetPlatform: constructor start, name: sam
TargetPlatform: constructor start, name: variants

Hope this gives somebody a clue.

Version 1.5 is working on Vista - at least blink successfully uploaded. So, i guess the fix on 1.5.1r2 does not work for Vista.