Arduino com port not found

Hi, I'm having a bit of the trouble with the COM port in the arduino uno, when I plugged my arduino to my computer, the COM port does not show and the USB says "Unknown USB device (device descriptor request failed)" and I went trough the hassle of unplugging, uninstalling, plugging, restarting, drivers, and i cant find the reason on what is causing this error

What type of computer and which operating system. I would guess it is some version of windows. Try with only the arduino and nothing else in the USB port. It is seeing the Arduino but does not know what it is, you probably have to add a driver (software).

I'm using Windows 10, and I tried installing CH34X but it did not work, I tried some random drivers but it also did not work, I tried the arduino drivers and it did not work, all it did was saying that "Your currently on the latest version of the driver"

Welcome to windows. The only thing I can suggest is take a good look at the board and see what the USB interface chip is. There are several variations and I have no clue as to what chip your Arduino has. Can you try a different board and or a different computer? I used Linux for over ten years and I am no longer that familiar with windows.

I'll give a go at Linux then, just got to make a double boot thingy in my computer and i'll see if it works, if it doesn't you'll probably see me around these forums again

Let us know if it works. I am using Linux Mint sylvia, cinnamon 64 bit. If you do add yourself to the dialout group or it will not work. This is the method I use. It was a one time thing, did it and it still works after several upgrades.

If Linux does not see board Go to terminal and Run:
Type 'groups', is 'dialout' there ?
sudo usermod -a -G tty yourUserName
sudo usermod -a -G dialout yourUserName
Log off and log on again for the changes to take effect.

Just fixed it, all I did was pressing the arduino board really hard, for some reason, eletronics really is strange sometimes

1 Like

Yeah, it sometimes works. And other times, it makes the matter worse. (Which can't be solved using brain, use muscles, lol)

Thanks for the update! I would mark that board as unreliable, from your description you caused something mechanically to move recreating contact. Best have a spare just in case. If you are experienced you can troubleshoot it and find the bad connection.

Quite often an in focus picture of both sides of the board can help just in case it is a clone.
It is possible to weaken the USB connector which can often be fixed with some simple fine soldering.