Arduino display only half a screen

Hi all. Just struck an annoying problem. My programs in Arduino are now only showing on half a screen of my laptop. Also the letters have become very large. Everything else on the laptop is fine. It is just the Arduino. I have windows 10 and am using a Lenovo.
Almost impossible to work my programs like this. The bottom half of the screen is black.
Minimising doesn't work. How can I fix this?

Like this?

If so you just need to drag down the border between the 2 parts of the screen.

Font size can be adjusted in file -> preferences; mine is set to 14, not sure if it is the default.

Did yours change?

I have fixed the font size in arduino using the edit button. For no reason at all the characters had suddenly gotten huge. Every other app was ok.
I also now have a black strip taking up about a 1/3 of the screen on my laptop for the sketches. First it took up 1/2. All other apps are still ok. How do I get back to full screen?
Another problem is how to log out from arduino forum. I always seem to be logged in already when I want to make a new post. Or is this the norm for arduino to be always logged in. I am not talking about the sketches I have. I have always presumed when you want to go to the forum that you would have to log in.

Yes just like that. Used the double headed arrow on the border to try to drag it down. I also had a computer guy trying the same thing. It is not working.


It might be caused by your interface scale setting in the Arduino IDE. Increasing the interface scale causes everything in the Arduino IDE to get bigger, including the font.

Open File > Preferences from the Arduino IDE menus. Then check what the "Interface scale" preference is set to. Usually it is best to just leave the "[] Automatic" checkbox checked so that the IDE will pick the right scaling, but you can uncheck that box and then adjust the "%" to whatever you prefer.

Hi, The automatic box is checked. If I uncheck it 100% is showing. But as I am only getting arduino display on 2/3 of my laptop screen this is not 100%.
So what do you suggest now? Should I try increasing to say 120%. But then you would think it is going to try to overlap on the screen. I don't want to make it worse than it already is. I have been using the sketches as it is now only displaying on 2/3 of my lap top screen.

Hi, My font size is 29. I am happy now with the size of my letters. I still have only 2/3 of Arduino showing in my lap top screen. The bottom 1/3 is a black strip. If I uncheck the automatic interface scale setting I get a manual setting of 100%. But I am not getting a full screen as this would suggest.

@petercl14 which version of the Arduino IDE are you using?

I don’t know which version it is. Where can I find the version then I will let you know, if this will help. Tried everything. Bottom third of lap top screen still black. Tried decrease indent in edit. Didn’t work. Double headed arrows doesn’t work. Living with it but would like full screen again.

In the title bar

My version is 1.8.13. Which would be a later version than 1.8.5.

OK, great. Arduino IDE 1.x has an advanced setting that controls the minimum height of the black output panel at the bottom of the IDE window. You can customize it to your preference by following these instructions:

  1. Select File > Preferences from the Arduino IDE's menus.
  2. Click the link on the line following "More preferences can be edited directly in the file".
    This will open a folder named something like "Arduino15" (depending on your operating system).
  3. Close all Arduino IDE windows
    The Arduino IDE overwrites the preferences file on exit, so it is necessary to exit the Arduino IDE before manually editing preferences so that the IDE won't overwrite your changes.
  4. Switch back to the file browser window that has the "Arduino15" folder open.
  5. Open the preferences.txt file you find in that folder in a text editor.
  6. Find this line:
  7. Adjust the preferences as you like.
  8. Save the file.
  9. Start the Arduino IDE again.

You should now be able to resize the output panel to show the number of lines you set in the preference. If you set it to console.lines=0, then you will be able to hide it completely.

Thanks in0. Changed the console lines to 0. Still have a light blue strip at the bottom of the screen 9mm wide. Below that a dark blue strip 5mm wide with the lines "arduino nano atmega 328p".
Possibly this was how it was originally. No more black strip. I guess some kind of a glitch in the computer caused it in the first place.

That sounds like the expected appearance. There is a bar that shows the progress and summary of the results of operations done in the Arduino IDE (e.g., compiling, uploading).

No, that "black strip" is the output panel (AKA "console"). It is there that the compilation and upload output is shown. This is extremely important information when something goes wrong because it will contain the detailed error and warning messages you will need to troubleshoot the problem. This is why the Arduino IDE is not configured by default to allow the output panel to be hidden. So make sure to remember that it is there and open it up whenever you have a problem.

What should the setting be then to show the black strip. I still get an error warning in the blue strip but what seems to be missing now is the space that the program takes up. This info must have been shown previously in the black strip as you suggest. I have set the console.lines to zero. What do you suggest it should be so I don't miss any important info?
I changed it from 4. At this setting the bottom 1/3 of my lap top screen was black. Is this the acceptable setting for the output panel? I am sure it wasn't this large originally.

The console.lines preference only sets the minimum height for the console. You always have the option of hovering the mouse pointer over the border until it turns into a and then click and drag to increase the height of the console panel so that you can read it. In this way, you can hide it when you don't need it and then open it back up as much as you like when you do need it.

The only problem is that when the minimum is set to 0, it allows it to be resized until it is not obvious there even is a console panel. So this might be problematic for someone who is not super familiar with the Arduino IDE. But as long as you remember that this thing exists and that it contains valuable information when there is an error, it should be fine.

Arduino IDE 2.x allows the Output panel to be closed, but it automatically opens it up whenever there is new output. So hopefully this will strike the right balance between making the information visible while also preserving screen real estate.

Well, I think the idea is to make it fairly prominent so that beginners will be sure to spot the information there. We already very often see newcomers here reporting some tiny fragment of the error output, and then have to explain to them that they must scroll that console pane up to see all the important information. If it was set to be even shorter, then that might be even more of a problem. So this stems from the intent that the Arduino IDE provide a gentle learning curve. But of course the IDE is also meant to be used by advanced users as well, and this is why the advanced console.lines preference was added.

So configure it however you like.

I think the change might have been you adjusting the interface scale settings.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.