Arduino IDE fails with ArrayIndexOutOfBoundsException

I have a Windows 7 SP1, 64 bit machine.
Arduino IDE version = 1.6.5

When I try to run the Arduino IDE, the splash screen displays for a moment and then disappears. That’s all.
This happens whether I run from the installed version or the unzipped version (Windows ZIP file for non admin install).

I’ve searched the web and forum for an answer but nothing I’ve tried has solved this problem

When I try to run the IDE (debug version) from the command line I get this:

C:\Program Files (x86)\Arduino>arduino_debug.exe
Loading configuration...
java.lang.ArrayIndexOutOfBoundsException: 3
        at processing.app.windows.RegQueryParser.parse(RegQueryParser.java:29)
        at processing.app.windows.RegQueryParser.<init>(RegQueryParser.java:14)
        at processing.app.windows.Platform.getFolderPathFromRegistry(Platform.java:71)
        at processing.app.windows.Platform.recoverDefaultSketchbookFolder(Platform.java:60)
        at processing.app.windows.Platform.init(Platform.java:51)
        at processing.app.Base.guardedMain(Base.java:153)
        at processing.app.Base.main(Base.java:137)

C:\Program Files (x86)\Arduino>

I ran the arduino.exe --l4j-debug command and got the following log file.

Version:	3.7
CmdLine:	C:\Program Files (x86)\Arduino\arduino.exe --l4j-debug
WOW64:		yes
Working dir:	C:\Program Files (x86)\Arduino\.
Bundled JRE:	java
Check launcher:	C:\Program Files (x86)\Arduino\java\bin\javaw.exe (OK)
Loading:	C:\Program Files (x86)\Arduino\arduino.l4j.ini
Add classpath:	lib\antlr.jar
Add classpath:	lib\apple.jar
Add classpath:	lib\arduino-core.jar
Add classpath:	lib\bcpg-jdk15on-152.jar
Add classpath:	lib\bcprov-jdk15on-152.jar
Add classpath:	lib\commons-codec-1.7.jar
Add classpath:	lib\commons-compress-1.8.jar
Add classpath:	lib\commons-exec-1.1.jar
Add classpath:	lib\commons-httpclient-3.1.jar
Add classpath:	lib\commons-lang3-3.3.2.jar
Add classpath:	lib\commons-logging-1.0.4.jar
Add classpath:	lib\ecj.jar
Add classpath:	lib\guava-18.0.jar
Add classpath:	lib\jackson-annotations-2.2.3.jar
Add classpath:	lib\jackson-core-2.2.3.jar
Add classpath:	lib\jackson-databind-2.2.3.jar
Add classpath:	lib\jackson-module-mrbean-2.2.3.jar
Add classpath:	lib\java-semver-0.8.0.jar
Add classpath:	lib\jmdns-3.4.1.jar
Add classpath:	lib\jsch-0.1.50.jar
Add classpath:	lib\jssc-2.8.0.jar
Add classpath:	lib\pde.jar
Add classpath:	lib\rsyntaxtextarea-2.5.6.1+arduino.jar
Launcher:	C:\Program Files (x86)\Arduino\java\bin\javaw.exe
Launcher args:	-splash:./lib/splash.png -Dsun.java2d.d3d=false -Xms128M -Xmx512M -classpath "lib;lib\antlr.jar;lib\apple.jar;lib\arduino-core.jar;lib\bcpg-jdk15on-152.jar;lib\bcprov-jdk15on-152.jar;lib\commons-codec-1.7.jar;lib\commons-compress-1.8.jar;lib\commons-exec-1.1.jar;lib\commons-httpclient-3.1.jar;lib\commons-lang3-3.3.2.jar;lib\commons-logging-1.0.4.jar;lib\ecj.jar;lib\guava-18.0.jar;lib\jackson-annotations-2.2.3.jar;lib\jackson-core-2.2.3.jar;lib\jackson-databind-2.2.3.jar;lib\jackson-module-mrbean-2.2.3.jar;lib\java-semver-0.8.0.jar;lib\jmdns-3.4.1.jar;lib\jsch-0.1.50.jar;lib\jssc-2.8.0.jar;lib\pde.jar;lib\rsyntaxtextarea-2.5.6.1+arduino.jar" processing.app.Base
Args length:	668/32768 chars
Exit code:	0

Any Suggestions?
Thanks,
Greg

I tried rebooting and it still does the same thing. At the bottom of the splash screen it says "Loading configuration" right before the splash screen disappears and the IDE apparently crashes.

I tried both version 1.0.6 and 1.6.4 and they both work fine.
It must be a problem with version 1.6.5.