Arduino IDE won't start after i tried to install ESP32

Hello Guys

First, i want to wish a good christmas.

So, i bought the Book “The official ESP32-Book”. I wanted to make some projects with the ESP32.
I went through the Book. First i needed to install PuTTY to do some configurations. I didn’t figured out how to write command there but never mind… then I installed Python 3.7.2. There I used all the presets and at the finish I choosed the option where the Path limmit was removed I think…
Then, in the book, they say you need to change the Environment Variables “Path”. I don’t know if I should change the “Path” in the Python installation before. I dind’t figured out what the meant in the Book.
You see in the picture.

Now, in the book stand to open cmd and type “python” in and now python will start. But by me, there was just an error that that command was unknown. so I go on. now i installet Git 2.20.1. I cloned the existing reposotory. see picture. after that i should start the get.exe in the new folder. worked. i startet the Arduino IDE and it worked. but when i tried to upload the sketch to the ESP32, the Arduino compilier couldn’t find a file that should be in the new folder, cant remember the name. so i wanted to reinstall the IDE, downloaded the Arduino ide 1.8.8. When I start it, there is this little loading window, but after a second, it close itself. i run the Arduino debugfile but it close itself after starting… same with Arduino IDE 1.8.7. So the IDE wont start, no matter what i do…

I use the Geekcreit ESP32 board.

Sorry for some English-Faults.

Thanks very much!

That book is either outdated or else written by someone who doesn't know what they're talking about. There is now a much easier way to install the ESP32 Core for Arduino. The installation method you attempted should only be used by advanced users who want to participate in beta testing of the latest development work.

You first must undo whatever mess the manual installation created. You should have installed the package to the [ARDUINO_SKETCHBOOK_DIR]/hardware/espressif/esp32 folder. You now need to delete that folder.

After doing that, the Arduino IDE should start. Now you can proceed with the correct installation process:

  • Start the Arduino IDE.
  • File > Preferences
  • In the "Additional Boards Manager URLs" field, add this URL: https://dl.espressif.com/dl/package_esp32_index.json
  • Click "OK".
  • Tools > Board > Boards Manager
  • Wait for the downloads to finish.
  • Scroll down through the boards list until you see "esp32 by Espressif Systems". Click on it.
  • Click "Install".
  • Wait for installation to finish.
  • Click "Close".

You will now find a list of ESP32 boards in the Tools > Board menu.

So, i tried to find this <[ARDUINO_SKETCHBOOK_DIR]/hardware/espressif/esp32> folder. Couldn’t find it.
In my hardware folder isn’s such a folder with that name. So I loaded a backup of my Windows. I reinstalled the newest Java an Arduino IDE… still not working. After I open the Arduino IDE, it close it self.
Same with the Debug-Programm. Maybe it’s a problem with Windows and the System variable “PATH”.

But thanks for your answer and the better way to install new boards…

Your IMG_5093.JPG:
IMG_5093.JPG
More bad advice from the book author. I recommend returning it for a refund since it’s garbage. You should never install anything to the Arduino IDE installation folder (as recommended by the book). The reason is that everything in that folder will be lost every time you update to a new version of the Arduino IDE.

You need to delete the folder C:\Program Files (x86)\Arduino\hardware\espressif (or the equivalent on your computer).

I did that. I removed every espressif-file from my system but the Arduino IDE still wont start.
When i open it, the loading window crash every time by the point "Boards are loading" (in German "Boards werden geladen").

Any Ideas?

So, i solved the problem… there were some wrong ESP32 Files in < C:\Users\Nicolas\AppData\Local\Arduino15 >
I deleted the < Arduino15 > Folder, reinstalled the Arduino IDE 1.8.8, added the
< https://dl.espressif.com/dl/package_esp32_index.json > to the Prefernces and it works now…!

Thanks for your help and i wish good last days in 2018

I’m glad to hear it’s working now. Thanks for sharing your solution. I’m sure if anyone else has this problem they’ll be very grateful.