Arduino Mega 2560 is not recognized by Windows


I have a connectivity problem between Windows and Arduino Mega 2560 R3 (Chip ATMEGA 2560 16AU).

Two days ago I installed version 1.6.7 Arduino IDE on a laptop with Windows 10 OS.

The first day you use it, the Arduino was recognized by my laptop assigning COM3 and everything worked well, but the next day (yesterday) did not recognize, the classic sound when you connect a device via USB will not be heard and the IDE on the part of ports you can not select this.

I would like to know to be and how I can fix this.

Several people have reported issues with Windows 10. Don't know.

When I bought my clone mega2560 windows 7 didn’t recognized it at all but after 2 days of searching I found a solution.Install the file I have attached…it’s some kind of problem with USB to serial connection or something I’m not sure and the drivers provided by arduino don’t work.Maybe it will fix your problem too.

CH341SER.ZIP (198 KB)

1 Like

If you bought it in China you indeed need to install the correct driver. It's indeed probably a CH341 which you can find here: (Link to actual manufacturer instead of boggy file on a forum...)

But if it worked before then that's not it. Because even when you plug in a USB device for which you don't have drivers Windows plays the sound.

If it's a real Arduino Mega (so with another ATmega16u2 as USB Serial converter on it) then change is you might have corrupted the program in that other ATmega16u2. You can try to burn the program into that again but you need a programer or another Arduino to act as a programmer.

If it's a China clone, check Device Manager to see if it really doesn't show up. If it doesn't, buy a new Mega :)

1 Like