Arduino mkr wan 1300 setup device fails on IOT cloud

Hi, I am a newbie to IoT so I have been using the out of the box Mkr wan 1300 to set up a LoraWan connection. Yesterday all worked Ok I went through the setup selected the board and it appeared in the Devices list as MKR wan 1300. I even achieved a send of some simple text message which arrived on the dashboard. I have an Arduino Pro gateway working all wonderful. I then wanted to tidy things up and repeat the install using exactly the same kit. I deleted the device and started to add it again. This is where I hit the problem

  1. Setup device, “Arduino MKR WAN 1300 found”
    2.1) Make your device IoT-ready, Tick in stage 1
    2.2) Make your device IoT-ready, “retrieving DevEUI from your board” FAILS
    “failed to start the Lora Module”
    I have reinstalled the Agent a number of times both 64 and 32 bit.

Part of the log from the “Agent”

Serial Ports:
[
{
“Name”: “COM7”,
“SerialNumber”: “”,
“IsOpen”: true,
“VendorID”: “0x2341”,
“ProductID”: “0x8053”
}
]
{
“P”: “COM7”,
“D”: “Failed to start module\r\n”*
}

Interestingly if I use the “FirstConfiguration” from the “MKRWAN” example it works as it appears to use the library “#include <MKRWAN.h>”

“Welcome to MKR WAN 1300/1310 first configuration sketch
Register to your favourite LoRa network and we are ready to go!
Your module version is: ARD-078 1.2.3
Please make sure that the latest modem firmware is installed.
To update the firmware upload the ‘MKRWANFWUpdate_standalone.ino’ sketch.
Your device EUI is: aXXXXXXXXXXX9
Are you connecting via OTAA (1) or ABP (2)?”

If I use the same sketch but from “MKRWAN_v2” it gets a similar error to the

“Welcome to MKRWAN1300/1310 first configuration sketch
Register to your favourite LoRa network and we are ready to go!
Failed to start module”

I’m guessing its an issue with libraries and possibly the fact that I did use “MKRWANFWUpdate_standalone.ino” on the board so it not exactly the same as when I first went through setup.

I have tried doing the setup of the board on the IOT cloud as a 3rd party device and have again got it to work and sent some simple text messages. Its just very frustrating, I must be missing something really simple.

any ideas would be welcomed.