Arduino Nano does not upload. "can't open device "\\.\COM4": Access is denied."

Hello everyone, I'm having some problems with my Arduino NANO. I have tried to upload a program to my board multiple times and it is not working. It faintly blinks the RX light but does not upload the program. Here is the error message. C:\Owen\Arduino\arduino-builder -dump-prefs -logger=machine -hardware "C:\Owen\A - Pastebin.com

I have not done anything different, but because I have had no success with IDE 1.6.9, I also tried 10 and 8 with no success. It was able to upload before, but not any more. I have tried many different computers and it still does not work. I need my code to upload by Sunday, as I am making a gift. The circuit is done and the schematic is here.

Thanks! opencircuit74

What the heck?

You get access denied AND a sync error? I don’t know how that’s possible…

Access denied means some other program is trying to use the serial port (some software that is meant to interact with a device on serial port assumes any serial port you connect is the device it’s meant to work with, and begins trying to talk to it). But that should stop the process, I don’t understand how a sync error could then be shown. Th

Does that mean I could get this fixed by Sunday?