Arduino on Linux/Manjaro --> ESP8266 Sketch Upload fails suddenly.... only Arduino-Boards work

Hi,

i use Arduino with Arch Linux (Manjaro 21.0.7 XXFCE).
Yesterday, everything worked fine.
This morning, i had strange outputs in the Serial.Monitor (theres another Post of me in the forum).

And now, since a few hours, i am not able to upload Sketches on my ESP8266.

When i start uploading, it say:

Connect...... _______ ...... _______ ..... ._______

And thats it.

But uploading on an Arduino Nano works.
So the problem seems to be the ESP.
But i have tried out several ESPs and they all don't work (and worked yesterday).

So i removed the ESP from the Board Library and reinstalled -> Same problem.

And then is deciced to set up Manjaro completely new and downloaded a fresh installation of arduino (by Manjaro Package Manager) and then; same problem again ;-(

I'm absolutely helpless, does anybody have a suggestion what could be the problem?

Best wishes
E.

Make sure you have the correct port for the ESP8266 selected from the Arduino IDE's Tools > Port menu.

If you don’t know which port it is, you can find it like this:

  1. Unplug your Arduino board from the computer.
  2. Select Tools > Port from the Arduino IDE's menus.
  3. Note the ports, if any, listed in the menu.
  4. Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  5. Plug your Arduino board into the computer.
  6. Select Tools > Port from the Arduino IDE's menus. - The new port listed in the menu is your Arduino board.

Hi,

i have the correct port selected and usw Arduino now for a few month.
SInce yesterday the port worked well. And if i connect an Arduino Nano for example it works.
Only with an ESP8266 it doesnt work.

First i thought, that the ESP is damaged so i tried another one - same fault.
So i tested it on my windows machine --> everything works (also with the ESP).

So i installed Manjaro Linux completely fresh and also Arduino.
Added the board url and installed the ESP via board manager and : Again it doesnt work...

Any further suggestions?

Hello all,

I have just encountered criticism in the German section of the forum because I asked the same question in the German and English forums at the same time (and unfortunately used a different user here in the English forum for the post I had created for my son...in the german forum its the user "basementmedia").

Here is the same post in ther german forum:

I just wanted to point this out and hope that no one here is angry with me for it :wink:

If you have any tips on how I could solve my problem, I would be happy to hear from you.

Many greetings
Daniel

Hello again,

thanx to a user of the german forum section i have a temporary solution:

Settings prior to uploading the sketch:

Boardtype: Generic ESP8266
Flash size: 4MB
Reset method: " no dtr (aka ck)"

Then press Flash button (or Ground D3 (GPIO0) on Wemos D1 mini)
Press Reset shortly
Then release Flash

Press upload in the IDE

Then the Upload works.

I also found out, that the reason for this bug seems to be related to the current Linux Kernel:

https://www.spinics.net/lists/linux-usb/msg216039.html

Some Users report, that downgrading the kernel solves the problem.
But in my case also downgrading did not do the trick.