Arduino UNO + Sensor Shield V5.0 = PC Absturz

Hallo und guten Tag,

Problem:

  • PC ist mit dem Arduino UNO ueber ein USB Kabel verbunden
  • auf dem Arduino UNO steckt ein Sensor Shield V5.0
  • an diesem Sensor Shield V5.0 wurde an den Stromanschluss
    ein Akku Pack 18650 (3,7V + 3,7V) angeschlossen

Wenn das AKKU-Pack angeschlossen wird stuerzt der PC ab.
Hierfuer suche ich eine Loesung !

  • PC mit dem Arduino UNO und USB Kabel - funktioniert

Gedanke: ist hier ein Fehler im Masse-Anschluss

an den Sensor Shield V5.0 sollen 5 Servo´s betrieben werden.

  • darum das Akku-Pack

Quelle: Robot Arm Arduino Tutorial | Gesture Controlled (Part 2) - YouTube

wuerde mich auf Anregungen zur Fehlerbehebung freuen :-))

mfg Ralf / selli

Sorry, meiner Glaskugel fehlt leider das fernglas, drum sehe ich nicht in Deine Bastelecke. Und was meist du mit 'stürzt der PC ab' ?? BlueScreen?? PC reset? Welches Betriebssystem? Läuft die Geschichte, wenn der Arduino nicht mit dem PC verbunden ist?also ein Testsketch auf dem Arduino, der das Sensorschield mit einem am Schield angeschlossenen Servo anspricht.?
Akkupack richtig gepolt angeschlossen?
Für effektive und zielgerichtete Hilfe brauchen wir Infos.

1 Like

Foto vom Aufbau. Von Oben.
Foto von der Unterseite des Shield.

Ist es dieses Shield?

In der Beschreibung Sensor Shield V5.0 - ProtoSupplies steht:
2-Pos Screw Terminal

  • GND = Ground for separate power supply!
  • VCC = Positive voltage from separate power supply. Typically 5-6V for servos, but can be other voltage as required by the system.

Note: With the SEL jumper installed, there must not be external power applied to the 2-pos screw terminal or damage may result since it will short the external and on-board power systems together.

Hast Du den Jumper SEL (auf dem Foto gelb) gesetzt oder gezogen?

Grüße Uwe

Hallo und guten Tag,

Das ging aber fix. Hatte ich so nicht erwartet.
Zu den Fragen:

  1. Akku Pack ist richtig gepolt (siehe Bilder)
  2. Ein Test Sketch läuft auf dem Arduino.
  3. Der Rechner schaltet sich komplett aus. Muss neu gestartet werden.
    Ich ziehe immer den Netzstecker. Nur Power Butten reicht nicht :frowning:
  4. PC Betriebssystem ist Windows 10
  5. Arduino Software ist aktuell

Ich möchte das Ganze aus dem Video nachbauen. Darum habe ich mich an das
Video gehalten.

Wenn ich den Stecker neben der Stromversorgung (SEL) entferne
kann ich mit dem PC arbeiten und er stürzt nicht ab.

Ich hoffe Deltaflyer das hilft Dir erstmal weiter bei der Glaskugel.
Danke für die Fragen. Ich hoffe die Antworten helfen Dir.

my_xy_projekt:
Ich poste mal einige Bilder - Hoffe es geht und man kann alles wichtige erkennen.



Danke jetzt schon für jegliche Hilfe.

mfg Ralf / selli

Hallo ich melde mich nochmal

uwefed:

Zu deiner Frage:

  • Ja ich habe dieses Sensor Shield V5.0

Im Video ist der Jumper (geld) 1:31 Time gesteckt. Darum habe ich ihn auch gesteckt
gelassen. Damit Stürzt der Rechner ab.
Wenn ich Ihn ziehe Stürzt der Rechner nicht ab.

Ich habe das Ganze mal ohne PC getestet.
Also Arduino UNO und Sensor Shield V5.0 + Akku-Pack

Wenn ich den Jumper gesteckt lasse leuchtet die LED (rot) neben der Stromversorgungs-
anschluss.
Ziehe ich den Jumper geht diese aus.
Vielleicht liegt hier mein Denkfehler.

gestecker Jumper - interne Stromversorgung = LED (rot) leuchtet
gezogener Jumper - externe Stromversorgung = LED (rot) aus

Ich hoffe das beantwortet deine Frage uwefed.

Danke

mfg Ralf / selli

Nachtrag:

Jumper gesteckt:

Jumper entfernt:

Dann musst Du wohl den Jumper ziehen, bevor Du den Arduino mit dem PC Verbindest

Dir ist schon klar, dass deine 18650 Zellen Betrug sind?
8800mAh sind in dieser Größe bisher nicht möglich (außer vielleicht in einer Entwicklungsabteilung).

Richtig!
In klein steht noch 3,7V 11,8Wh drauf. Das sind dann rund 3200 mAh.

Wenn an dem Board der "SEL" Power Selector Jumper gesteckt ist, wird die Eingangsbuchse mit dem 5V Anschluss des Arduino verbunden. Der bekommt also so 7-8,4V je nach Ladezustand der Zellen!
Du hast Glück das sich Dein Rechner nur abgeschaltet hat und nicht gleich ein Teil des Mainboard sich verabschiedet hat!

Gruß, Jürgen

Der Jumper trennt die Servoversorgungsspannung von den 5V vom USB.
Wenn Du in den Klemmen eine Spannung einspeist muß der Jumper entfernt sein. Ansonsten speist du die 7,4V in die 5V Spannung der USB ein.
Du hast Glück daß weder der Arduino noch der PC das Zeitliche gesegnet hat, Beiders ist möglich und wahrscheinlich.
Ich vestehe daß Du das so machst wie das Tutorial das vormacht und Du nicht das Wissen hast zu erkennen daß das falsch ist. Aber unter uns das ist falsch und der Tutorautor macht einen riesen Blödsinn. Ich rechne den Autor zu der Gruppe von Bastlern die nicht verstehen, was sie machen aber glauben es anderen beibringen zu müssen.

Natürlich leuchtet die LED wenn Du nur die Batterie anschließt nur wenn der Jumper gesetzt ist.
Wenn Du den Arduino an USB anschließt dann leuchtet die LED auch bei gezogenem Jumper.

Grüße Uwe

1 Like

hallo und guten tag,

kurze rueckmeldung. bin leider erkrankt.

habe das problem aber loesen koennen.

der erste NUC war sehr empfindlich und hat registriert das der jumper SEL gesetzt war.
somit hat er zuviel strom aus der USB-buchse gezogen und ist immer abgestruerzt.

nachdem er entfernt war geht alles.
der zweite NUC war nicht so empfindlich und ich konnte SEL entfernen bzw. auch gesteckt lassen
und es hat funktioniert.
jetzt habe ich ihn entfernt und es funktioniert alles super.

irritierend ist die LED auf dem board die leuchtet wenn SEL gesetzt ist und nicht leuchtet
wenn SEL entfernt ist. hier sollte MANN/FRAU nachbessern.

soweit erstmal

danke fuer die vielen REs

mfg selli / ralf

Gute Besserung.
Uwe