arduino uno usb device

Hi I just got my arduino and I am trying to install it. my OS is Win XP. I am following the windows installation link instructions and when I plug in the USB A-B cable, It detects it as a 'USB device' not a 'Arduino Uno'. when I acknowledge the bubble, the 'new hardware installation' dialog comes up and says it is just a USB device. If I look at the Device Manager, it does not show up in the COM & LPT secion but in the USB devices. I confirmed that it is the Arduino because I can unplug it and it goes away. I tried using the 'new hardware installation' dialog procedure but when I went to the arduino driver directory, it would not acknowledge a driver there. Some blogs I searched said to try updating the hardware in the device manager under the 'USB device' entry but that would not acknowledge a driver either. I am at a loss of what to do next, Can anyong help with this. Thanks.

Try this Modified IDE:,73748.0.html


Thank you for your response but unless I am missing something, I don't think it is going to work. The only COM port that my PC sees is COM 1 which is the one with the original RS-232 serial port. The test you gave wants a terminal program which you will have to enter a COM port number to communicate with the arduino and there isn't one. so unless I am missing something, I am going to need more info on what I am doing wrong. The only thing that I could see which are communication lines are the ones marked 0-Tx and 1-Rx. Does the loop-back test use these for a serial port? if so, I would have to make a cable with a connector. thanks.

I am so sorry, my copy buffer did not copy what I wanted :blush:

Try this one:,118440.0.html

Hi, thanks for getting back to me. Can I trust this download? I have had several viruses introduced in the last 2 years from downloading different utilities.

Many members (Including myself) have downloaded this with no issues. Just click the download for the setup_Arduino_ERW_1.0.1i_20121020.exe file. I will talk to the author and see if he would be interested in moving it to GiHub or something.

Hi, The only reason I ask is Web-Of-Trust gave the download site a red indicator saying it was untrustworthy.

Try this then ;)


Yeah, I just got the PM from eried that he moved a copy to Github...

Hi, I downloaded and installed the software for the enhanced IDE, went thru the whole process and loaded all the different arduino drivers. I went to the IDE and used the circuit one example. I compiled and uploaded. what was strange is it uploaded but I didn't have it plugged in and it didn't complain. I plugged it in but it still is not recognizing where the arduino port is and it will allow me to still upload. I looked at the tools->serial port and it all it sees is COM 1. according to the 'Arduino Enhanced Release 1.0.1i for Windows' page it should automatically fix this but I see nothing that it was fixed. when I plug the usb cable with the arduino, it is also telling me it found new hardware. Is there anything I am doing wrong. I am ready to pull my hair out. thanks.

« on: August 13, 2012, 10:02:03 PM »

Have you tried a reboot after the installation? Is there another USB port on the PC or do you have a USB hub?

Hi, I have a wireless USB wifi adapter and a wireless USB mouse, no hub. I did try rebooting but still nothing. It still comes up and says 'new hard ware found, 'USB device' and proceeds to the new hardware setup dialog. Arduino still sees only COM 1. any other suggestions? thanks again for any help. I appreciate it.

Do you have another USB AB cable (Printer cable, etc)?

Secondly, can you get me a screenshot of what you see when the device wizard takes off and you manually select the driver, when you get to the “driver folder” do a <Cntl+Alt Prt Sc> and bring up “mspaint” paste it, save it and attach it (Additional Options…)to this thread.

Hi, I did try another USB cable but that didn't help. I am going to get another one from work and try it out. After work, Ill get those screen shots. thanks.


here is the screen shots. It was weird. when I came home I plugged in the arduino cable and the balloon for new device 'found said ‘Arduino Uno’ but quickly went to ‘usb device’. when I looked at the device manager, it had the ‘usb device’ in the
‘COM and LPT’ but it did not say anything about Arduino Uno. As you can see from the one screen shot, when I went to find the driver the ‘OK’ was greyed out. hope this helps. Thanks again.

hardware_driver_install.bmp (351 KB)

device_manager.bmp (804 KB)

What happens when you uninstall the unknown device?

Hi, I think I fixed it and I didn't try this before was because the enhanced version said it will setup the port automatically if it couldn't connect. I though when you installed the enhanced version it automatically put in the drivers also. When I plugged the usb cable again, and got the 'new device found' dialog , I pointed it to the folder where the enhanced IDE version drivers were, not the original ones I had unzipped. Why there were no drivers there, I don't understand. that is why in the screen shot I sent you it didn't find anything. Once I installed the drivers from the enhanced version, it worked! Thank you again for all your help, I appreciate it. hopefully this is fixed now and I won't have to post in this thread anymore. See ya around the forum!

Whew...I was running out of ideas :astonished:.

Hope it continues to work out for you.