Arduino Yun Wifi no longer working

Hi, I recently received my new Arduino Yun last night. Installation and setup was fairly simple and straightforward, and I had it up and online in minutes.

However, today the wifi and networking no longer work. I haven't changed anything or attached any peripherals since initially setting the board up. I've tried resetting the device by holding the WLAN RST button for longer than 30 seconds, in order to reset it to factory settings, but that hasn't helped.

I can still upload and run sketches to the AVR chip, but the rest of the unit seems unresponsive. Occasionally, when holding the WLAN RST button, the blue WLAN LED will flash as if things are normal, and as long as I hold down that button I can see the Yun's wifi network and connect to it, during which time the system behaves as a brand new unit, allowing me to visit the configuration page and so on. But as soon as I let go of the button, the blue LED turns off, the Yun's wifi signal disappears, and the board resumes behaving as a normal Leonardo board.

Thanks in advance for any and all suggestions.

Edit: I found the YunSerialConsole example sketch, and am able to see the boot process of Linino, as well as access the terminal. Not sure what to do from here, though.

I do see the following error crop up in the boot process text though:

[    5.290000] Error: Driver 'gpio-keys-polled' is already registered, aborting...

Edit2: Not sure what was going on, but all seems normal now.

I have same problem, First the wifi will be instable, some time show acces point other will be missign, I press more than 30 second and then will be ok, But now the blue led blinking , and the access point is missing all the time

Can any body help....


Take a look here

Hi, I have the same problem not working anymore the Wifi.
I try pressing the 30 second Wifi button and nothing.
When I connected the Ethernet I can saw a message “There was a problem last time I tried configuring wireless network.
Check the following log for details of what went wrong (Show)”
And also the ethernet connection is intermitent and with a putty too.

I attached the error in the Error.txt file

Please help

Error.txt (11.1 KB)

I fixed!, Thanks Federico!...

I did that:

  • First enter to myyun.local using ethernet network.
  • I enter to Configure and changed the time zone to America\New York
  • Entered in advanced mode and turn on the Wireless Arduino - XXXXXXXXXXXXXXX
  • Press the WIFI reset button for 60 seconds

And the factory configuration come back again.

How do you "Entered in advanced mode and turn on the Wireless Arduino - XXXXXXXXXXXXXXX"? I tried this by entering "Interface" and adding it. When I tried to connect to the Yun via my PC, it said I had "limited connectivity" and I could not access arduino.local or

Hello everyone!

I went through the beginning of a tutorial to connect the YUN to my student residence wifi, however this didn’t work.*I suspect it has something to do with my residences wifi policy (the provider is ASK4 wireless).

Anyways, I wanted to try and connect the YUN to another network (my phone’s hotspot). This does not work because I am no longer able to access the dear aduino. He does not appear on the wifi networks. Neither can I get him to recognized via ethernet cable. I tried resetting the board by pushing (both, independently) reset buttons for 30s. Good old pluggin in and unpluggin didn’t help either :confused:

Anyone have any ideas?

  • This is the message I got

“The server at arduino.local can’t be found, because the DNS lookup failed. DNS is the network service that translates a website’s name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network.”

Please don't double-post.

I answered you in the thread you opened.


I have somewhat similar a problem. I was trying to reset my Arduino Yun (WLAN button pressed for more than 30 seconds), but it just kept on blinking for about 10 minutes. Then I finally got impatient and restarted the Yun. After the restart, there was no WLAN (blue) or USB (white) LED blinking or glowing anymore. I am unable to connect through the Wifi network, the Yun does not create it's own Wifi network and unfortunately when connected via Ethernet (which seems to have worked for most of the people in this post), I can still not navigate to arduino.local or

So I have a feeling that somehow only the AVR is still functioning (because I can still upload sketches) and nothing else.

I have updated the firmware to the latest version (OpenWrt-Yun 1.5.3). Is there a way to connect or reset, if the Ethernet does not work? Can I upload a sketch to check in the console if the Linino interface still functions.

Hope this query is still relevant to this post. Thanks in advance!

Please upload the YunSerialTerminal sketch and keeping the serial monitor open restart the linux side with the Yun RST button.

Please copy the output of the sketch here

WLAN led is on and can not see YUN wifi in networks

this is the code Angelo9999

Nouveau document texte.txt (11.6 KB)

@ihebkhlifi10, please start a new thread, and start over with your problem.


i have an arduino yun
Wlan LED works and USB LED works but No wifi signal !!
plz help

ihebkhlifi10: i have an arduino yun Wlan LED works and USB LED works but No wifi signal !! plz help

@ihebkhlifi10, please start a new message thread. Jesse

HI, need help with not working YUN, this is where I’m:

  • I can download a sketch using the USB port
  • The WLAN led is off
  • 5 or 30 sec reset doesn’t make any difference
  • attached is what I get from YunSerialTerminal

any help will be very much appreciated.

YunOutput.txt (10 KB)