avrdude: stk500_getsync(): not in sync: resp=0x30

Hi, I'm Marco from Italy!
It's my first Arduino Uno! In mu PC at home I can't work and I have this message "avrdude: stk500_getsync(): not in sync: resp=0x30" and I have no flashing in Tx and Rx leds. If I disconnect USB cable I have the same thing! It's seems like Arduino doesn't talk to the PC.
I made the SAME installation with SAME drivers to my PC at work and...everythings works in the good way!
I have read every forum about this problem and I try somethings but no result to work at home!
Someone can help me?
Thanks a lot!

most often this message indicates that you should select another board type in the GUI under tools menu. Have you tried that?

Thanks for answer!
I checked...I have the same board type of the PC at office but in the PC at home it doesn't work!!

check this - http://www.instructables.com/id/A-solution-to-avrdude-stk500getsync-not-in-syn/ -

Had that link worked, it would be terrific.

Alas it doesn't work for me.

My scenario is that I bought one, then another one.

They both work.

Then I bought another and it had this problem.

I even bought a "Genuine" Uno.

It too doesn't work. SAME PROBLEM.

Tried other board types - as suggested in other posts from people with similar problems.

Weirdly enough I can still talk to my first Arduino.

So I am really at a loss to what is going on.

So you have 3 Arduino's and 2 PC's
All the Arduino's work with PC1 but only one does work with PC2

  • try another cable
  • try another USB port of your PC if possible
  • reinstall the drivers (remove COMports from device manager)

I have 4 Arduinos, and 2 pcs.

One of the Arduino may be faulty.

One is working and can be programmed. As this is my alarm clock, it is now only done from my laptop.

The other two just won't flash from either.
One of those has been tried on a third pc and also fails.

The "faulty" one works in that I can upload the BLINK sketch and it works.
Other sketches upload but as some of the I/O lines are suspect, may not work.
Suffice to say the LED stops blinking when the new sketch is uploaded. Then starts blinking when the BLINK sketch is uploaded.
Also there are no errors.

The two new cards give this "not in sync" error.

One is a freetronics one and is a genuine Arduino uno.

Add me to the ever growing list of "not in sync" errors. I'm using an Arduino UNO R3 / ZUMO Shield combo.
Had been working for a couple of hours then all of a sudden I started getting the subject error.
It started as an intermittent failure and is now solid. I've tried all the tips suggested in this post as
well as others in this forum. None work. I've even update Arduino 1.0.1 to 1.0.3 and updated the USB drivers,
all to no avail.... ?????

There seems to be so many 1000s of people having the same problem, I would think
the Arduino development team might look into this, and either find a way for better
software driver installation, or else come up with a more bulletproof uploader program.
Maybe one that has some option settings.

Also, I think the problems have become worse with the newer R3 boards, ie, new
drivers, larger upload packets, and faster transfer baudrates.

One thing to try is see if the driver for the board is installed properly .... go to
Control Panel > System > Hardware > Device Manager, and see if the board shows
up in the Ports section when you plug and unplug the board.

There seems to be so many 1000s of people having the same problem

It's not "the same problem." It's a generic error message that gets reported for LOTS OF DIFFERENT PROBLEMS.

I'm pretty sure that the R3 boards have the same bootloader and speeds as the previous Unos.

To the person with the Zumo shield - does it start working if you disconnect the shield?

As the nominal "owner" of Optiboot, I'd be willing to expend some effort to debug some of these mysterious failures (especially the ones that went intermittent to solid broken), but doing so over the net seems hopeless. I'd need to have your physical board in my possession, and since I'm not a "vendor" I can't offer a replacement board or anything while I work on it. I'd be willing to mail it back if I get it working, though.
So if you're willing to mail me your "dead" arduino for debugging, or if you're local to the SF Bay Area and have one of these consistently failing boards, PM me for contact info...


There seems to be so many 1000s of people having the same problem

It's not "the same problem." It's a generic error message that gets reported for LOTS OF DIFFERENT PROBLEMS.

I'm pretty sure that the R3 boards have the same bootloader and speeds as the previous Unos.

Yeah, I know, still there are so many problems with uploading, especially with the newer
boards, that it seems someone might do some rethinking along the lines I mentioned.

ALSO - it would be nice if the bootloader and uploader-dude s.w. were more conducive to
wireless programming, using XBees for instance. This would probably entail adding:

  1. ability to choose lower upload baudrate.
  2. ability to use shorter packets.
  3. adding longer turnaround ack wait times.

I would do this myself, as I use XBees all the time, but my knowledge of AVR assembler
and the tool chain s.w. is extremely limited.

I just got the Uno in the mail and got that error out of the box on COM3. I changed it to COM4 and it works to upload. I changed it back to COM3, same error. Back to COM4 and it works again. Good luck!

I have this message "avrdude: stk500_getsync(): not in sync: resp=0x30" and I have no flashing in Tx and Rx leds. If I disconnect USB cable I have the same thing! It's seems like Arduino doesn't talk to the PC.
Someone can help me?

Just change the COM port to another. It just worked for me. All the best

Add me to the list as well. I'm a long time arduino user and have implemented literally thousands of them. Now with my HP laptop, I suddenly cannot talk to these boards (Uno R3, Deu, Dec, Sanguino, Mega and our own brand - with and without the FDTI chip - all of these boards in quantity, so it's not just a single board or board type)
Devices show up in the com ports, I have tried switching ports, (both physically and forcing a change in the device manager and by plugging more than one board into the machine to "push" the new board to a higher com port), I have uninstalled the devices and reinstalled/ updated the drivers from the latest driver files that come with 1.05 (as well have tried 23, 22, 18, 17 - because this used to work)
I can see the device in the Arduino IDE and board type is correct (it even auto selects the correct one for me so there must be a handshake of some type going on).
Trying to upload a sketch yields "not in sync: resp 0x30. And no tx/rx lights blink.
ALL of these boards work fine on other systems both mac and PC. So it must be my PC.
I have tried removing the HP security tools (thinking that they may be preventing the ports from allowing these non standard devices in). But then these tools would have been on the machine from the get-go and this used to work.
I have tried older IDE's (back to 17, as I say, this used to work)
I have tried changing baud rates at both the IDE level and the port level in the device manager's advanced tab
I have tried programming the board on another system (this works) and then bringing those boards to the HP and running code that interfaces with those boards (like serproxy and AS3 GLue) which works fine on other systems, but fails to work on this PC.
ALL other port type devices - keyboards, mice, harddrives, cameras etc. work flawlessly on the HP (even ones that you would think would have driver issues, seem to just work - like a mac mouse or keyboard)
I'm just baffled. HP is no help - all ports working nominally.
It was suggested in another post to try a Parallel to USB hardware adapter but there was so much suspicious unsigned driver software associated - not to mention the suspect poster in the forum - that I didn't take the risk.
I have trolled the forums both here and abroad to find suggestions and have tried them all.
I've tried different USB cables (but really these work on other machines, so that's not it)
I've tried the loop back test - and this is the only clue - If you fire up the IDE and use the serial Monitor, the board remains "linked" to the IDE even when you fire up Arduino IDE without board plugged in. So when I type anything in the serial monitor I get a correct echo back - with no board attached! Me thinks there is a flaw in the serial monitor (and yes, my machine) if this can work. If I choose a different port, then the serial monitor fails. But the port where the board used to be attached works great.
Any suggestion welcome.

In my case it was a Renesas usb driver for other devices (like mice and keyboards). I use a lot of unique peripherals and this was obviously need to make them work correctly.
Removing this has killed the use of all my chosen USB peripherals and I'm now searching for compatible hardware and drivers that will still allow the arduino to function as well.
I thought this was the whole point of multiple ports - so that you could run different hardware.
What I don't know is if this is an issue with the arduino implementation of the port calls or an overbearing Renesas driver hammering away on all ports, drowning out meek whimpers from the arduinos.

Um help? I tried to burn bootloader but it said avrdude = not in sync resp 0x30 and I know someone is going to comment read it again! But, um, help at least? ^___^

So you've tried to upload your program to your Arduino and are getting the error message
avrdude: stk500_getsync(): not in sync: resp=0x30

It seems that, periodically, the Arduino software decides to use a different COM port, especially if you've restarted your computer. Your problem seems to be that your Arduino isn't connected to the proper COM port. Or rather, your computer is connecting to a COM port that isn't the same one that your Arduino is connected to.

Take a look at the bottom right corner of your Arduino program page. In white you will see the COM port that your computer is trying to use. It will probably be COM3. Your Arduino is probably connected to another COM port (Make sure your Arduino IS connected to your computer via your USB cable!).

Click on "Tools"
Click on "Serial Port"
From the drop-down box, you might see two (or more) COM ports.
One of those COM ports has a check-mark beside it.
The other COM ports are unchecked.
Click on one of the unchecked COM ports.
The check-mark moves to this new COM port.
Upload your program to your Arduino.

If unsuccessful (assuming you have more than two COM ports listed under "Serial Port"), repeat the above using a different COM port. If you've only got the two COM ports listed, then your problem is something other than the above.

Hope this helps.

Bob M.

PS - Make sure you've tried to upload your program to your Arduino in the current session. If you've restarted the Arduino program but haven't tried to upload your program to your Arduino, all of the available COM ports may not be shown when you click on "Tools", "Serial Port", etc